Can't login to sonarqube when restore database

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this


I’m facing a big issue when trying to restore database et turn on my sonarqube instance.

I cant log in to sonarqube even the user admin exist in the database. I tried to update the password manually in postgresql but nothing change.

I’m using the verstion7.0

Looking forward to hear from you soon.

Thank you!


Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

xxx → 7.9.6 → 8.9.7 → 9.3 (last step optional)

You may find the Upgrade Guide and the LTS-to-LTS Upgrade Notes helpful. If you have questions about upgrading, feel free to open a new thread for that here.

You can also check the documentation on Authorization > I lost the admin password


Thank you foy your reply.

I tried this option : update users set crypted_password = '88c991e39bb88b94178123a849606905ebf440f5' , salt= '6522f3c5007ae910ad690bb1bdbf264a34884c6d' where login = 'admin'

I saw the changes in the database but when i log in i see “Authentication Failed”

I think the version of database that made this problem because i did a restore.