SonarQube 8.8.0 - admin pass reset doesn't work. ( Unknown hash method )

Must-share information (formatted with Markdown):

  • which versions are you using: SonarQube 8.8.0 Community Edition
  • how is SonarQube deployed: zip
  • what are you trying to achieve: Administrator password reset
  • what have you tried so far to achieve this: Reset admin account via SonarQube guide, different crypt strings from

I’m a bit lost and hope someone could help in this thread. We are using SonarQube together with Nexus,Sonar-Scanner and GitLab.

The problem is that our colleague who was managing all that apps left the company without providing the admin credentials or any useful documentation…

I tried the official SonarQube password as also some options i found on stackoverflow but nothing helped.
Not sure if this is related to our old version we are still using as it’s 8.8.0. Is a upgrade needed to latest 9.9.0 to get it working again ?

The only thing i can find in the logs is following line. I enabled debug mode:

DEBUG web[AYaS5ksTdgFSD0RcAAAf][auth.event] login failure [cause|Unknown hash method [PBKDF2]][method|FORM][provider|LOCAL|local][IP||][login|admin]

Best regards,

Hi Henrik,

Welcome to the community!

Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.9 → 8.9.10 → 9.9

You may find the Upgrade Guide and the LTS-to-LTS Upgrade Notes for 7.9 to 8.9, as well as the LTS to LTS release upgrade notes for 8.9 to 9.9 helpful. If you have questions about upgrading, feel free to open a new thread for that here.

If your error persists after upgrade, please come back to us.


Hi Ann,

For the moment there is no way for help to get back the admin account ? Before i upgrade on a test server i would like to verify some changes and without a working admin account…i can’t do any relevant things.

This procedure sadly doesn’t work for the Postgres DB.

Is it maybe possible to create a second local admin account directly in the Postgres ( Version 9.6 ) without going through web interface ( which won’t work anyway as i don’t have a workable admin account ) ?

Maybe a small step-by-step help would be very helpful here.


Hi Henrik,

The procedure for resetting the admin password has changed slightly from then to now, altho it’s not clear to me whether the DB structure has.

You could certainly try creating a second account, although it’s not clear to me why that would succeed when resetting admin doesn’t.

You’re 2 LTS versions behind. Once you catch up, there may be more we can do to help.