Cannot setup organization with multiple owners

I am an admin of https://github.com/wildgums and I am trying to add this organization. However, it keeps asking me for a login. While checking the requests, I see this:

{“errors”:[{“msg”:“User is not admin of the ALM organization”}]}

However, I just double checked and am part of the “owners” group in GitHub. Note that this is the first organization where there are multiple owners (the other ones I added so far only have a single owner (me)).

Anything specific I need to do?

Hi @GeertvanHorrik,

Welcome to our community forum !

Could you detail the steps you took to add the organization ?

Thanks

  1. Login using a GitHub account
  2. Plus button => Create new organization
  3. Choose organization on GitHub
  4. Select WildGums (app already installed, so I hit Configure)
  5. Select all repositories (or specific ones, doesn’t really matter) => save
  6. I am redirected back to SonarCloud, but then it requires me to login again

I have inspected the requests via Edge (chromium), and get this error message:

https://sonarcloud.io/api/alm_integration/show_alm_organization?installationId=7531191

The response is:

{“errors”:[{“msg”:“User is not admin of the ALM organization”}]}

I am 1 of the 2 owners in the GitHub organization. Note that, due to alphabetically ordering, I am the 2nd in the list. Maybe that makes the difference?

Hi,

Can you try to uninstall the GitHub app and then retry exactly what you did from step 2 please?

Thanks,
Benoît

  1. Uninstalled the app
  2. Gave access to all repositories => install

Same issue, different installation id:

https://sonarcloud.io/api/alm_integration/show_alm_organization?installationId=7579525

{“errors”:[{“msg”:“User is not admin of the ALM organization”}]}

Thanks for trying.

That shouldn’t make any difference. We’ll investigate further and come back to you!

2 Likes

Any updates on this? Our trial for the self-hosted version (which we used to evaluate the branches feature) has expired and we want to move to the cloud, but this is blocking us.

Thanks!

I’ve tried removing the other owner (so I am the only owner left), but it’s still not working. Not sure if there are other things that could prevent this? I think I have everything allowed in GH.