Cannot create users using Firefox in 9.1.0.47736

We are using Sonarqube Developer edition, version 9.1.0.47736
Users cannot be created using the firefox browser. Clicking the “Create” button in the “create user” popup does nothing. It works in chrome though.

Welcome @Spiros_Ioannou ,

Could you share the version of the Firefox that you are using? You can find it in Help → About Firefox window.

And which operating system are you using to access SonarQube?

@Spiros_Ioannou Do you still see the issue? On Firefox 94, I cannot reproduce the error.

Hi, we tried Firefox 95.0.2 on both MacOS and Linux and it doesn’t work. I just tried on a Windows 10 VM and it did work! This is really strange.
Clicking the “Create” button on the popup on Mac and Linux Firefox does nothing.


Spiros Ioannou
Technical Manager, IT/SM
Electrical Engineer, PhD
www.inaccess.com
M: +30 6973 903 808
W: +30 210 6802 358

Thanks for your reply.

I still cannot reproduce, unfortunately. Can you check the console and the networks tab? Do you see any errors? Is there an XHR request being sent to api/users/create?

No, no messages in console, and no requests XHR or normal ones in network tab.

So strange. I know one of my colleagues managed to reproduce, but I’ll have to wait for them to return from their holidays. I’ll keep you posted.

Hi there, we “officially” stopped investigations on our side since we can’t reproduce it consistently.

Feel free to get back to us with a complete and detailed way of reproducing, if you manage to do so :man_shrugging:.

Thanks for your report and your answers along the way.

Hi Philippe, it is 100% reproducible. It just never works on our tests. And yes I know it’s very strange.
I’m not sure what else we can do.
Unfortunately no one in the tech team has windows OS so it’s a recurring issue.
Kind regards,
-S

When running a reproducible case, could you check that the issue persists if you run Firefox in private mode? What if you disable all the Firefox extensions?