"Bulk apply permission" on projects not working

Hello,

We are using 8.9.8 LTS version (Enterprise Edition) and have create a permissions template to provide users access to baseline projects (Administer Quality gate, profiles, execute analysis and create projects). When we apply this template to all our existing projects under Administration -->Projects -->Management, the message indicates success but when the user with the permissions logs in then they do not have the relevant permissions.

@ganncamp Can you please help with this ?

Hey there.

Please do not tag individuals in a thread who are not already engaged in a thread. Instead of bumping this to the top of Ann’s list – it actually moves it to the bottom.

Please read our FAQ, specifically this section .

Ok.Got it.

Any update on this ?

Hi,

How many projects are you updating at once? Are users gaining permissions directly in the templates (assigned as individuals) or via groups they’re members of?

 
Ann

Initially we tried updating 1000 projects and it did not work. Then we tried apply on 5 projects alone. Still the permissions are not taking effect. The users are gaining permissions from the groups they are part of.

Hi,

I’ve seen weirdness with group permissions in the past, but never been able to pin it down.

For a single, sample user can you tell me:

  • how many groups the user is in
  • what permissions each group (obvs redact the names if needed) has in the template

Once you “bulk apply” the template to a single project, can you then check the project permissions (Project Settings → Permissions) to verify that the permissions have been reset per the template? And then have the user verify whether she does / doesn’t have access to the permissions?

 
Ann

This is the template where the user has access.

These are users permissions.

I applied the below template to one project and when I log in as that user I cannot baseline projects.

Hi,

Can you show me the project permissions, now that the template has been applied?

 
Ann

This the screenshot showing the project permissions

Perfect.

Now, your test / example user is a member of both of these groups (plus, obvs, sonar-users)?

 
Ann

The user is only part of rebaseline group.

Okay. So can you share what your user is/isn’t seeing in terms of permissions?

I would expect the user does not have the ‘Project Settings’ menu, but does have the ability to

  • see the project (it’s public, so that’s a given, but worth stating since it’s in the template)
  • see the project’s source code (ditto)
  • mark an issue False Positive/Won’t fix
  • change Security Hotspot status
  • execute an analysis

 
Ann

The user I gave given these permissions needs to manage their project and baseline accordingly. Create versions under Activity → They should see the pencil icon to edit the versions. The issue is they are not seeing that edit (pencil) option.