Bitbucket unable to fetch Sonar data

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
    We’re trying to upgrade to 7.9.1, but the upgrade failed, so we reverted to the old 7.3 instance and db snapshot. But, we now see this error at

Server ID

Invalid server ID. Please provide a license for the following server ID:

I believe this is causing an issue for our bitbucket plugin, which is now giving us this error for new PRs:

Sonar data unavailable
Was not able to fetch data for Sonar project “”. Either your pull request has not been analyzed yet, a non-existing Sonar project is referenced, you use the commercial branching feature of SonarQube >= 6.7 but have not enabled this in the repository settings or you have upgraded SonarQube without restarting the plug-in (disabling and re-enabling in the UPM). You can configure the Sonar project in the
repository settings.

  • what have you tried so far to achieve this
    I tried disabling/enabling the sonar server on the instance it runs on, and disabling/enabling the sonar plugin in bitbucket. I reran the build between all steps, and bitbucket still cannot get the Sonar data.

This was working correctly before, all I had done is re-attached sonar to another DB snapshot (a snapshot taken of the DB when it was working correctly yesterday afternoon)

If I look at a repo in sonar, I see this error banner at the top:
Analyses suspended. The server ID is invalid. Please ask for a license for the server with ID: *******Go to License page.


Can you give details on the 7.9.1 upgrade failure. Cause you need to get that done. 7.3 is waaaaay past EOL. 7.9 is past EOL too, but you’ll need to upgrade through it to get to 8.9 (the current LTS) and then possibly on to 9.0, the current version.