Sonar integration with Bitbucket (GIT)

Hi team,
i am working on sonarqube and i want integration with Bitbucket for code quality repport.

  • SonarQube version is 5.01, Bitbucket version is 5.9)
  • I want sonarqube integration with Bitbucket for code quality repport.
  • i tried to find the plugin at sonar community but could not found. Is it possible or not?
  • i have done this via Jenkins but i want directly sonar integration with bitbucket.
    So please help me, how can i integrate the sonar with bitbucket directly.

please do the needful.
Any help will be appreciated.

Hello Vipin,

welcome on our community forum!

First, I would recommend you to upgrade to a more recent version (we are currently running 7.7 version of SonarQube…) as 5.01 is quite old.

You’ll find here the news of the release of 7.7 version which offers PR Decoration in BitBucket :slight_smile: and official announcement here.

A quick point: to upgrade from 5.0 to newest version, you should follow the LTS path: 5.0–>5.6 LTS–> 6.7LTS and then 7.X version (next LTS should arrive before summer).

Enjoy the journey and new BitBucket integration :slight_smile:



Hi Carine,

Thank you so much for your reply.
So finally we have to upgarde (LTS path: 5.0–>5.6 LTS–> 6.7LTS and then 7.X version) as you suggest.
One more question: Currently i am using Bitbucket5.9 so will it be compatable with sonar 7.7 or we have to upgrade this also?

You will need to upgrade as well BitBucket to, at least, 5.15 version.

Thanks a lot Carine, you make my day.

1 Like

Hi Carine, I hope you are doing well.
Actually i tried to installed Sonar 7.8 but getting connection refused error.
I installed open jdk 11 on one of my server and tried with that, but no success.
With same configuration with jdk 8 sonar 5.0.1 is working fine on same server.
please see the logs as well–>
2019.07.02 21:18:25 DEBUG app[o.e.c.t.TransportClientNodesService] failed to connect to node [{#transport#-1}{ec8Retj6Q4ak6xLXFKrV0w}{}{}], ignoring…
org.elasticsearch.transport.ConnectTransportException: [] connect_exception
at org.elasticsearch.transport.TcpTransport$ChannelsConnectedListener.onFailure(
at org.elasticsearch.action.ActionListener.lambda$toBiConsumer$2(
at org.elasticsearch.common.concurrent.CompletableContext.lambda$addListener$0(
at java.base/java.util.concurrent.CompletableFuture.uniWhenComplete(
at java.base/java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(
at java.base/java.util.concurrent.CompletableFuture.postComplete(
at java.base/java.util.concurrent.CompletableFuture.completeExceptionally(
at org.elasticsearch.common.concurrent.CompletableContext.completeExceptionally(
at org.elasticsearch.transport.netty4.Netty4TcpChannel.lambda$new$1(
at io.netty.util.concurrent.DefaultPromise.notifyListener0(
at io.netty.util.concurrent.DefaultPromise.notifyListeners0(
at io.netty.util.concurrent.DefaultPromise.notifyListenersNow(
at io.netty.util.concurrent.DefaultPromise.notifyListeners(
at io.netty.util.concurrent.DefaultPromise.tryFailure(

    at io.netty.util.concurrent.SingleThreadEventExecutor$

Caused by:$AnnotatedConnectException: Connection refused: /
at Method)
… 6 common frames omitted
Caused by: Connection refused
… 10 common frames omitted
2019.07.02 21:06:09 DEBUG app[i.n.b.AbstractByteBuf] -Dio.netty.buffer.checkAccessible: true
2019.07.02 21:06:09 DEBUG app[i.n.b.AbstractByteBuf] -Dio.netty.buffer.checkBounds: true
2019.07.02 21:06:09 DEBUG app[i.n.u.ResourceLeakDetectorFactory] Loaded default ResourceLeakDetector: io.netty.util.ResourceLeakDetector@2a2daf70
2019.07.02 21:06:09 DEBUG app[i.n.util.Recycler] -Dio.netty.recycler.maxCapacityPerThread: 4096
2019.07.02 21:06:09 DEBUG app[i.n.util.Recycler] -Dio.netty.recycler.maxSharedCapacityFactor: 2
2019.07.02 21:06:09 DEBUG app[i.n.util.Recycler] -Dio.netty.recycler.linkCapacity: 16
2019.07.02 21:06:09 DEBUG app[i.n.util.Recycler] -Dio.netty.recycler.ratio: 8
2019.07.02 21:06:09 DEBUG app[o.e.t.ConnectionManager] connected to node [{sonarqube}{pJreLXGTSn-MQ-c2xMMkzw}{v-f-uTpZRQCI0iDLCn-8lw}{}{}{rack_id=sonarqube}]
2019.07.02 21:06:09 INFO app[o.s.a.SchedulerImpl] Process[es] is up
2019.07.02 21:06:09 INFO app[o.s.a.ProcessLauncherImpl] Launch process[[key=‘web’, ipcIndex=2, logFilenamePrefix=web]] fr: