Azure Devops Quality Gate stay pending

Hello ! While going through a pull request in Azure DevOps we always end-up waiting for the response of the Sonar Quality Gate, checking on the project’s pull request on SonarCloud shows that the scan already happened, but the response wasn’t sent to Azure DevOps even though the tokens are still valid.


While checking for an answer to that question we tried affecting a provider in the project settings as well as filling up a valid token in case the one already in place was expired, but after saving those changes and refreshing the page the provider field return to it’s original empty state.

Since we didn’t receive any instruction about how the change went, it is hard for us to understand if those changes went live or if they were dismissed.

Could this issue originate from SonarCloud ? Or could it be something else ?

Hello @afabis

So if I understand well, the issue currently is that the Sonarcloud analysis is running fine, but the result of the analysis is not sent back to Azure Devops, right ?

In this case, can you make sure that your personal access token is set correctly at the project level OR the organization level ? (depending on how you have set up your project, more informations there : Azure DevOps | SonarCloud Docs)

If you are unsure, you can try updating both.

As for the provider, I can confirm you that when a value is selected and saved, the select shouldn’t go back to its empty state, but let’s focus on one problem at a time, let me know if updating the personal access token fixes your issue.

Best regards,


Hello Quentin,

We can confirm that the tokens of both Sonarcloud and Azure sides are set correctly, but we do have some new information regarding our Azure connectivity issue :

Our Azure Devops organization seems to be linked to another Sonarcloud organization (probably an older one we created back then), thus preventing us to connect it to this one since one organization can only be linked to one Sonarcloud organization.

This is for binding two organizations but do you think it can also impact us if we want to link only one project to our organization ?

Also we don’t have any information about that (probably) old organization and we wanted to know if it was possible to slip in DM’s, we need to know who’s its owner so that we can try to delete it and link the new one.

Best regards,


Hello @quentin.chevrin

I am working with Antony on this subject.

We would like to delete or deactivate this old Cegid instance from Sonarcloud.
We don’t know the owners of the instance and these owners are certainly not part of the company anymore.

This point is blocking us from creating mono repo


Hello @quentin.chevrin

We are still waiting for the resolution of our specific problem.
Is it possible to get a temporary dedicated support for paying plans?


Hello Kevin,

Really sorry for the delay. I’m back taking care of your issue now.
So, if I understand correctly, you want to unbind your Azure Devops Instance from a SonarCloud instance that you lost access to ?

Can you send me the Sonarcloud instance name that you want to unbind ?

Best regards,

Hello Quentin,

Speaking instead of Kevin here, yes that is the case, we would like to unbind it, and if possible also delete this instance.

This is the one we want to delete :

Thank you for your attention.

Best regards,

Anthony FABIS
DevOps Engineer

Product Delivery Excellence Department




Hello Anthony,

We can not find such organization on our side, seems life if it existed it has been deleted now.
So I am wondering :

  • Did you manage to fix the issue yourself since last time we spoke ?
  • Or there is something else going, in such case : Cab you to send me your Azure Devops Instance name so I can have a look on my side what might cause the issue ?

Second thing, I can see you also have a SonarCloud instance for Cegid linked to Laurent Arnal, so I guess this one is the new one that you want to use, right ?


Like I said in the second mail (that maybe never reached you), I misspelled the sonarcloud organization that we wish to see removed or unlinked.

This is the said organization :

The name of the organization is cegid-1.

Our current organization is this one with the name “Cegid Group”, this is the one we want to have linked to our Azure DevOps organization.

Our Azure DevOps organization is this one : (simply named “cegid”).

Sorry for that mistake on our part and thank you for your assistance.

Hello Anthony,

Thanks for the informations, I sent you a personal message with some information. Let me know if you can proceed with the deletion on your own with it or if you need further assistance.

Best regards,


Yes ! We finally managed to to it, as expected it was one of who coworkers and he managed to delete it.

Thank you for your help, hope you have a great day !

1 Like

Hello Anthony,

I’m glad it helped, don’t hesitate to reach out again in case any problem happens. We will make sure to answer faster next time, I apologize for the delay on this one.

1 Like

Hello again, even though we managed to link our Sonarcloud to our Azure DevOps organization we are still unable to receive the Sonar Gate Validation for a pull request, what we have tried :

  • Removing the PAT of the project and leave the one on the organization (while still keeping the Azure DevOps service)
  • Using a brand new PAT on the project
  • Using the same PAT as the organization level (which work 100%)

For every test, the pull request pass the Sonar Gate control (image 1) but won’t send the validation to Azure, forcing us to pass it manually.

Hello @afabis

Have you had a look at our documentation here :

If you don’t find anything useful, please have a look in Administration / Background Tasks and see there if you have no error or helpful message.

After those 2 checks, if you still have an issue, please send me a task ID so I can have a look in our log and what might go wrong.

Best regards

Hello, we did not find what we wanted in the documentation.

Here’s some Task IDs that illustrate our issue :









They all are from the same project and should all show the same problem.

Have a nice day :slight_smile:

Anthony Fabis

Hello Anthony,

I’ve had a look in our logs and for all the ID’s you provided I have the following error :
AzureDevOpsException: The Azure DevOps access token is not valid

So I think either the token you created doesn’t have enough rights
(it should be like this)

or it is not set at the right place, you can check at your org level that it shows something like this

Let me know if this helps you solve your problem or not

Hello again,

First of, thank you very much for taking your time on this issue,

For the organization PAT we do have the checkmark, this token is valid

But even with that (and after removing the token at project level) you saw the error we had

This time we tried multiple token at project level to see if we have the same problem

here are their ID’s :




Also here’s a screenshot of our token on Azure Devops side :

Thank you again for your response,

Best regards,

Anthony Fabis


We still have “Access token not valid”, one of our recent customer had an issue where he set the permissions right on the token but we realized together that the users he used to create the token didn’t have the permission to view and comment the project, which was the reason the access token was not valid to post PR decoration.

Is there a chance you could be in the same situation ?

If possible I would also be interested to see a screenshot of the “Create a new personal access token” page in your Azure Devops like this one but on your side (of course you can remove any sensitive informations) :


Best regards

Hello Quentin,

I can confirm that this is not a right issue : our PAT account is Admin of the project as you can see below :

Also here’s a capture of our PAT’s rights :

Have a nice day :slight_smile: