Automatic analysis for Github PRs stopped working, no new analysis activity

Our organisation uses Github with Automatic Analysis enabled across various repositories. Although there has been recent activity in Github, we have seen no new analyses run in Sonarcloud for the last couple of hours. I have seen one instance of an error reported, saying “An error has occurred with your code repository platform. Please try again.”. Following the docs, “trying again” would mean pushing changes to Github to trigger another run of the automatic analysis, but nothing is happening and there is no further information to go on.

Our projects do not use .Net so I would expect them to not be affected by the scheduled maintenance for .Net projects. I am not sure if this ongoing issue could be related.

Please advise how to investigate or resolve this issue.

Hello Arjan and Welcome to our Community!

GitHub had an incident around the time of your post, so just to be sure, do you still have the problem? When you see the error reported, do you also see there an analysis ID? If so, could you please share it, it would help to investigate the problem.

You’re right, you should not be affected by the .NET Automatic Analysis maintenance, neither by the Azure login issue.

Peter

I also have several repos configured with automatic analysis, and all of them have stopped scanning new PRs. I can see the PRs listed in the SonarCloud UI, but it just says First analysis in progress and never progresses. This behavior started yesterday, which seems to correspond with the two scheduled maintenances for Automatic Analysis I see on the Sonar status page.

There was previously also an error message, with an analysis ID, indicating that there is a problem with the connection to the repository, but those messages seem to have vanished from the UI. The resulting page, if I click on a link to the PR in the SonarCloud UI, is mostly just a blank page.

As with the original poster above, I’ve tried adding more commits without any effect. I’ve also tried closing/reopening the PRs, as well as disabling and re-enabling automatic analysis in the SonarCloud UI.

We’re also having this same problem on one of our repos. However, we have no errors. One background task did fail on June 7th but plenty succeeded after that. The last analysis on that repo was one June 10th. Since the 10th was a Saturday, it’s likely we didn’t have any new commits on PR’s until Monday the 12th. This entire week we haven’t had any analyses run, new or existing PR’s. Any ideas on how to resolve this? Thanks in advance!

Hello,

During the maintenance of Automatic Analysis on Monday, we added a --recurse-submodules parameter to the git clone command which we use before the analysis starts. So if a git repository contains bad submodules (for example a submodule with a broken link, unaccessible, etc), the git clone command will fail. We discovered that this was an issue with one of the projects using Automatic Analysis.

If a git submodule is not accessible, possible solutions could be:

  • Drop this submodule, if it is no longer used and left in the repo by mistake
  • Fix it by pointing to a repo that is found/accessible

Let me know if this helps

Peter

Hi,

We had the same problem and now we can see again all the missing PRS and new branches Sonar was not able to get but now we have the following message in all of them:

“First analysis in progress”

After almost a whole day the status did not change in any of the PRS, so it looks like something is not working. Any help?

Thanks for the reply, Peter. We do have a single submodule that is old and unused. I removed that and it seems to be working again!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.