About SonarQube, SonarLint & Eclipse Version Compatibility

(Josue ) #1

I’m trying to know what version match Eclipse STS 3.7.3 & SonarQube 7.3 with SonarLint cause I was having issues and couldn’t connect between them. Does anybody know about it?
Thanks a lot :slight_smile:

(Julien Henry) #2

Hi,

SonarLint Eclipse is compatible with SonarQube LTS+ (so 6.7+) in connected mode. You also need to have recent analyzers.
SonarLint Eclipse is tested with Eclipse 4.6+

Maybe you could share your error, so that we can help you?

(Josue ) #3

Hi,

thank you for your time. It seems like it could connect to the server but it couldn’t retrieve issues. I updated my Eclipse IDE and now is working. Maybe some kind of error during it instalation.

Thank you for your reply.
Regards :blush: