What should be SonaLint vs SonarQube version compatibility


(Itamar Pasalski) #1

The violations reported in sonarlint eclipse plug-in are not aligned with the violations reported by SonarQube server

I’m using in my project the following:

  • SonarQube - Version 5.6.1
  • SonarLint for Eclipse org.sonarlint.eclipse.feature.feature.group
  • Eclipse IDE for Enterprise Java Developers:Version: 2018-12 (4.10.0), Build id: 20181214-0600

Getting below exception in eclipse:
“The following plugins do not meet the required minimum versions, please upgrade them on your SonarQube server:
javascript (installed:, minimum: 4.0)
java (installed:, minimum: 5.1)
web (installed:, minimum: 2.6)”

(Julien Henry) #2

Hi @iPasalski,

SonarLint in connected mode get the same (SonarSource) code analyzers, rules and quality profiles than the server. We try to maintain backward compatibility in a way consistent with our LTS strategy: SonarLint should be able to connect to SonarQube LTS (currently 6.7) and more recent versions. Regarding code analyzers, it is a bit more complex to have a clear matrix, but we are trying to support all analyzers that were released at the same time, and then after the LTS.

For older versions like you have, there is no guarantee. We have no automated tests for such old version, so it might break at any time.

Also note that code analyzers have sometimes to adapt their behavior to SonarLint, so we may have to require people to upgrade their analyzers in order to have a good SonarLint experience. Each SonarLint release contain an hardcoded list of analyzer minimal supported version.

Hope that help.

(Itamar Pasalski) #3

you support third party scanning?
I guess that the cause of most of the misalignments
that our current rules configured in the SonarQube:
FindBugs Java 368
PMD Java 32
Checkstyle Java 20
SonarAnalyzer Java 11
Find Core Hacks Java 1
Total - 432 active rules

(Julien Henry) #4

SonarLint doesn’t support third party analyzers.