Upgrade community to developer edition

Hello everyone , I am new in this community :innocent:
At the moment I was on community edition 9.4.0 than I upgrade to community version 9.6.0 three weeks before now I wanted to upgrade to latest developer edition (9.6.1) .
I am using this helm repo ( https://SonarSource.github.io/helm-chart-sonarqube) .
Pipeline always fail when I try to commit or upgrade the tf file.
Can anyone help me about this upgrade procedure to the developer edition ?
What are the pluggins I have to use , which helm chart / version I have to put ?
I will be very thankful to you for the help :slightly_smiling_face: because I am trying to do this upgrade process from last 3,4 days and I am quite tired :face_exhaling:

It would be useful to understand the nature of the failure – what error message do you get?

Hi @Colin
Thank you for your response. :slightly_smiling_face:

I am using this repository ( https://SonarSource.github.io/helm-chart-sonarqube) and the chart version is ( 3.0.0) and the sonarqube version is (9.6.0 developer)

Error : timed out waiting for the condition

with module.sonarqube.helm_release.sonarqube, on …/sonarqube.tf line 1, in resource “helm_release” “sonarqube”: 1: resource “helm_release” “sonarqube” {

I am attaching some screeshot as well



Thanks for the details.

I’m not at all a fan of how we document which chart versions (I’m confused myself after reviewing it), but referring to the changelog – you should be using at least 5.0.6 rather than 3.0.0.

Can you give this a try and see if you get any further?

Hi @Colin

Yes I tried 5.0.6 with the same repo ( https://SonarSource.github.io/helm-chart-sonarqube) but didnt worked
So I downgraded from 5.0.6 to 3.0.0


In this repo (GitHub - SonarSource/helm-chart-sonarqube) you will see charts folder if you open it there are there folder
sonarqube-dce
sonarqube-lts
sonarqube

In sonarqube-dce folder (sonarqube chart changelog) upgraded version is 4.0.6 for sonarqube 9.6.1, however in sonarqube folder (sonarqube chart changelog) the one you share with me is mentioning 5.0.6 for sonarqube 9.6.1. I am quite confuse about this sonarqube and sonarqube-dce as I am upgrading from community to developer edition.
My comment are too long sorry for that but I will be very thankful to you if elaborate.
Thank you :slightly_smiling_face: