Update site URL https://eclipse-uc.sonarlint.org/ returns error Not Found

sonarlint

(Paul) #1

Cannot access Sonar Lint for eclipse at all.


(Adam GabryĹ›) #2

You have to verify your proxy configuration. I checked https://eclipse-uc.sonarlint.org/compositeContent.xml and it returns valid xml file:

<?compositeMetadataRepository version='1.0.0'?>
<repository name=""SonarLint for Eclipse Update Site"" type="org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepository" version="1.0.0">
    <properties size="1">
        <property name="p2.timestamp" value="1520528890"/>
        <!--
            http://www.epochconverter.com/ or http://www.onlineconversion.com/unix_time.htm 
        -->
    </properties>
    <children size="7">
        <child location="https://sonarsource.bintray.com/SonarLint-for-Eclipse/releases/3.1.0/"/>
        <child location="https://sonarsource.bintray.com/SonarLint-for-Eclipse/releases/3.2.0/"/>
        <child location="https://sonarsource.bintray.com/SonarLint-for-Eclipse/releases/3.3.0/"/>
        <child location="https://sonarsource.bintray.com/SonarLint-for-Eclipse/releases/3.3.1/"/>
        <child location="https://sonarsource.bintray.com/SonarLint-for-Eclipse/releases/3.4.0/"/>
        <child location="https://sonarsource.bintray.com/SonarLint-for-Eclipse/releases/3.5.0/"/>
        <child location="https://sonarsource.bintray.com/SonarLint-for-Eclipse/releases/3.6.0/"/>
    </children>
</repository>

(Paul) #3

Ok, but thats not the URL that I asked about. I was asking about the URL that is displayed in my marketplace. I get erros when i try to download from marketplace (possibly proxy related) but if i try to use the manual method to validate, then manual downlioad specifies the URL I supplied, not the one you tested.

I tried to access this via a direct internet connection and got the same result, which was why i raised this issue.

Are you suggesting that I should use the URL you specified rather than the one on market place website?

Edit: Ah Sorry, I just realised that eclipse adds the content.xml to the URL. So why is the working url using the node compositeContent, but eclipse is expecting content.xml? Any idea?


(Paul) #4


(Paul) #5

When I google for compositeContent.xml vs content.xml, I see quiet a few instance of the same issue. I havn’t found a definitive answer, but it seems to be that the update site mechanism requies a different URL to the marketplace mechanism. Is it the case that you only support marketplace? It looks like our network or proxy is is receiving an ssl certificate error when trying to access market place (specifically for sonar, it works for other market place downloads) Hence why i was trying to download manually via the update site mechanism.

Is there a way to manually download and install the sonar plug in, as I don’t see that i will get the ssl issue fixed anytime soon.


(Paul) #6

Looks like this may be related to this thread…


(Adam GabryĹ›) #7

I think you have a problem related with proxy configuration. I downloaded eclipse-jee-photon-R-win32-x86_64, launched it, opened Install New Software... and finally I see SonarLint components:


(Paul) #8

Yes, have been looking at this. At least part of the issue is the way the proxy is handling the ssl certificate. I have updated the jre to have the proxy generated certificates in its trust store, and I can now get the update to start, but its failed further in when it tried to collect the items. Not sure if this is because the content is actually using a different cert, or some other reason. Again, it would be much easier if you provided a bundle to download. Trying to get the ssl working through the proxy is hard work. (or I didn’t have to go through the proxy)


(Paul) #9

But I agree, I definitely think this is an issue caused by the proxy. And thank you for your help.