Eclipse-uc.sonarlint.org/ is down

(Patrik Suzzi) #1

I read in this bug that the sonarlint.org was down and now it seems fixed: Sonarlint.org is down

However, the web address for the eclipse plugin is still down.

Steps to reproduce: open https://eclipse-uc.sonarlint.org/

Another example : try to install the eclipse plugin by dragging an icon from the eclipse marketplace.

(G Ann Campbell) #2

Hi,

This URL is working fine (it’s the one linked w/in the site itself): https://www.sonarlint.org/eclipse/

Would you mind passing on where you found the other URL, please?

 
Thx,
Ann

(Julien Henry) #3

This is the one used by the update center. I will notify infra.

(Eric Hartmann) #4

@psuzzi, I’ve just checked, this web site is not intended to be displayed in the browser (indeed the 404 is expected on this one).

I’ve just tried inside eclipse to install it by adding https://eclipse-uc.sonarlint.org/ as an update site and everything is working well.

So on your installation with this update center, it’s not working ?
Can you provide more information (eclipse version, log inside eclipse) ?

Thanks

(Patrik Suzzi) #5

Thanks for the prompt response.

I tried to install the sonarlint eclipse plugin both via command line (eclipse -nosplash -application org.eclipse.equinox.p2.director … ) and from inside eclipse with the Help > Install new software.

Both the approaches failed

Since your installation works, I now think this could be a proxy problem.

Anyway, you can see the error log I receive at the bottom:

eclipse.buildId=4.8.0.I20180611-0500
java.version=1.8.0_191
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -product org.eclipse.epp.package.dsl.product
Command-line arguments: -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.dsl.product

org.eclipse.equinox.p2.transport.ecf
Error
Fri Apr 26 12:24:52 CEST 2019
Unknown Host: https://eclipse-uc.sonarlint.org/content.xml

java.net.UnknownHostException: eclipse-uc.sonarlint.org
at java.net.InetAddress.getAllByName0(InetAddress.java:1281)
at java.net.InetAddress.getAllByName(InetAddress.java:1193)
at java.net.InetAddress.getAllByName(InetAddress.java:1127)
at org.apache.http.impl.conn.SystemDefaultDnsResolver.resolve(SystemDefaultDnsResolver.java:45)
at org.apache.http.impl.conn.DefaultClientConnectionOperator.resolveHostname(DefaultClientConnectionOperator.java:262)
at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:161)
at org.apache.http.impl.conn.ManagedClientConnectionImpl.open(ManagedClientConnectionImpl.java:328)
at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:612)
at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:447)
at org.apache.http.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:884)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)
at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:263)
at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:60)

(Eric Hartmann) #6

According to this error :

It looks like the DNS resolution is not working, so something looks broken on your network or the proxy is refusing to connect to eclipse-uc.sonarlint.org

1 Like
(Didier Jachimski) #7

for me it’s the same problem !
I’m trying to install the plugin from the eclipse marketplace
the answer is -> Unknown Host: https://eclipse-uc.sonarlint.org/content.xml
eclipse-uc.sonarlint.org

(Patrik Suzzi) #8

Hi All, I realized that I encountered an issue with my System proxy settings. For my problem, you can close the issue. Sorry for the noise.

For those having similar issues on setting proxies, I was on linux and to solve my issue I had to configure my proxies from Window > Preferences > search Proxy; make sure that the http and https proxies were configured, and ensure SOCKS proxies were cleared (CLEAR button).

(Didier Jachimski) #9

I have a corporate proxy problem that I can’t solve for security reasons.
I’m going to get the binary directly from the plugins.
Thank you for your help.