Unable to upgrade/install v4.0 on Code Composer Studio using Eclipse v4.7.3

sonarlint
eclipse
upgrade

(Sujeeth Kolluru) #1

Versions Used:
Eclipse: v4.7.3
Code composer Studio: v8.3.0


SonarLint: v4.0

When I try to install or upgrade to v4.0 from the eclipse marketplace, It only lets me install v3.4. And during upgrade it only lets me downgrade to v3.4. See attached screenshot.

Steps:

  1. Install Code composer studio v8.3.0 from http://processors.wiki.ti.com/index.php/Download_CCS
  2. Open CCS or Eclipse and Search SonarLint on Eclipse Marketplace
  3. Install SonarLint v4.0
  4. See attached screenshot for the actual error received during install

(Sujeeth Kolluru) #2

I fixed the issue by installing mylyn.commons from http://download.eclipse.org/mylyn/releases/latest and then trying the SonarLint install. That worked.