Dependencies for SonarLint IDE


(Ankur) #1

I am trying to use SonarLint 4.1.0 on Rational Application Developer (RAD) 9.5.0.2, which is based on Eclipse platform 4.4.2.

The installation fails with this error - “Missing requirement: SonarLint for Eclipse 4.1.0.201901311043 (org.sonarlint.eclipse.feature.feature.group 4.1.0.201901311043) requires ‘org.eclipse.mylyn.commons.ui 0.0.0’ but it could not be found”

Is SonarLint 4.1.0 not compatible with Eclipse Platform 4.4.2 ? If not, can you tell me a prior SonarLint version which is compatible ? I could not find this compatibility information between SonarLint and Eclipse platform version anywhere.


(Julien Henry) #2

Hi,

We are using a component provided by the Mylyn project. Simply add an update site for mylyn and then install SonarLint. It should pull the dependency from there.
https://wiki.eclipse.org/Mylyn/Repositories

Probably:


(Ankur) #3

Thanks. I know how to resolve Mylyn dependency. My question was more towards finding a SonarLint version that is compatible with Eclipse Platform 4.4.2. Is there any compatibility matrix available between SonarLint and Eclipse Platform versions ?


(Julien Henry) #4

Hi,

We are currently running integration test with Eclipse 4.6+. It doesn’t mean it won’t work with older versions, but there is no guarantee.