Unable to reset admin password after oidc plugin locked out

Using the community 8.9.7 Sonarqube docker image and running Sonarqube in kubernetes. I have the openid plugin installed to login. This is currently locked. Attempting to reset admin password so I can login and troubleshoot the plugin error.

I have attempted to update following instructions here to update password:

I can see in the psql db that the password and salt have been updated and I get an update1 when I’ve ran the command however logging in using user=admin, passwrd=admin fails to authenticate.

Any ideas how I can reset admin password?


Welcome to the community!

What do your server logs say when you try and fail to log in?


The logs dont mention anything related to the login failure with admin:

ce.log has the following. I am aware of this and know how to fix but unable to login using admin:

WARN web[AYGKdx6AO7gcH0IeAAER][o.s.s.a.AuthenticationError] Fail to initialize authentication with provider ‘oidc’
java.lang.IllegalStateException: Retrieving OpenID Connect provider metadata failed

When I login using admin/admin as username and password I get an error on the UI saying that authentication failed

I have made the changes to the DB as per docs to update the admin password but this hasn’t worked.


Hello @lucky7865,

Welcome to the Sonar Community Forum! Thank you very much for reaching out and for creating this thread about your issue. I have tried to reproduce the behavior you have described but I was unable to. Could you verify that your provider settings are configured correctly on your properties file? Feel free to share any feedback on the thread.

All the best,