Unable to login into SonarQube ( console via SSO or local admin credentials

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this
  1. Currently using SonarQube version

  2. Trying to login into console using SSO but the login screen redirects back to login screen also tried to
    use local admin credentials but still same

  3. I have tried to restart the service and tried to reset the password but nothing works


Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.7 → 8.9.9 → 9.5 (last step optional)

You may find the Upgrade Guide and the LTS-to-LTS Upgrade Notes helpful. If you have questions about upgrading, feel free to open a new thread for that here.

For now, I would suggest trying a different browser and/or clearing your browser data to see if the issue resolves.


We will be planning to upgrade to the newer version but for now I did tried to changed the browser and even clear the browsing history but it still doesn’t work

Also no changes were made

As a next step, it would probably be a good idea for you to increase sonar.log.level in your conf/sonar.properties file to at least ˋDEBUG` and after restarting the service, attempt logins and see if there’s anything interesting in the web.log file