This Project Is Empty

Hi folks,

To help us investigate, it would be interesting to get logs of both scanner and server side processing, in debug mode.

For Maven or CLI scanners, just add -X to get verbose logs.

To get compute engine (server side) verbose logs, go to the system info page, and change log verbosity to debug, just before running the scanner. Once the background task has been processed, get the logs and reset to normal verbosity.

You can send the logs to me privately if you are concerned about privacy (julien.henry at

Thanks very much Julien! The logs have been sent just now.

Hi All,

i had the same issue “this project is empty” and i found a solution for it.
instead of running sonar scanner via command line : ./sonar-scanner …
i run it via maven, you can use this command (depending what you have declared on the pom file ) : mvn clean package sonar:sonar
then i got all the data on SonaQube.

I hope this will help you guys.

Yassine B.

Hi Yassine,

Thanks for chiming in!

If you don’t mind sharing, what version of SonarQube are you running?


Hi Ann,
I´d like to share solution on my side for issue “This project is empty”.
The issue was connected with “” file. After I renamed this file and re-run scan of the project analysis finally appeared in SQ. Thanks to Julien H. for pointing in this direction. For second issue of “This project is empty” , I had .yaml files in project to analyze but " YAML Analyzer plugin was not installed. After installing this plugin I was able to see analysis for my project. Thanks very much to all of you !

2 posts were split to a new topic: Can’t analyze Swift

Hi @Joso_Kosic,

Thanks for chiming in! Would you mind sharing the contents of your renamed file?


Even I am also facing the same issue. MSBuild is getting successful but unable to reflect in SQ dashboard. Getting Project empty. Please provide solution.

I am using Sonarqube 7.7 , MSBuild 4.6.1

#Configure here general information about the environment, such as SonarQube server connection details for example
#No information about specific project should appear here

#----- Default SonarQube server

#----- Default source code encoding

location of this file is : sonar-scanner-msbuild-\sonar-scanner-\conf

and I renamed this file from to

Hi Ann, please see attached screenshot

Hi @Joso_Kosic,

Thanks for sharing your properties file.

You have extensive lists of exclusions and inclusions defined. Since analysis produced the expected results without these properties, I can only guess that your inclusions and exclusions combined to an empty set.

Also, purely FYI, I don’t think sonar.leak.period does anything as an analysis property. This should be set in the UI, at global or project level.


The measures tab is empty for me except under Size which shows new lines of code:

Hi @smyrin

Thanks for the screenshot. Could you also provide logs, please?


I am still a SQ newbie and I don’t know where to find the logs. I changed to DEBUG mode but where on the server are the logs. For the build agent, also not sure how to set that to verbose from the command line. I am using a TFS vNext task and passing the following args:

/d:sonar.cs.vscoveragexml.reportsPaths="***.coveragexml" /d:sonar.cs.vstest.reportsPaths="$(Common.TestResultsDirectory)*.trx" /d:sonar.scm.provider=tfvc

Edit: I think I found the logs at SonarQube-7.6\logs. Only the web log changed after the build so I will send that.

Sent Julien logs.

Hey there,
same Issue here.
Background Tasks visible and marked as successfull, but the project is empty.
SQ Version 7.7 (build 23042) + postgres
Code: C# & VB
using SonarScanner for MSBuild 4.6.1

Already a solution available?

found a solution.

Switched back to SonarScanner for MSBuild 4.5

Seems to be an issue with the SonarScanner for MSBuild.

I am also facing the same issue …project folder is empty

I have the same problem.
But after I add my .classpath , .gitignore and .project files, the details displayed.

I had the same issue. Using -X option I discovered that the SCM plugin wrongly ignore all my files. Disabling the SCP plugin solves my issue

1 Like

Interesting. Can you share your .gitignore file?