The dreaded "This driver is not configured for integrated authentication"

Hi,

I am installing SonarQube Developer 8.7.0.41497 on Windows Server 2012 R2.
I use the term “installing” in the vaguest sense, as any “installation” that is “extract zip file, copy this file here, download this and copy one file somewhere” is not a good user experience in my option. You might be able to sense my frustration.

Anyway, I have followed the instructions in the documentation about downloading the jdbc driver 7.2 (and I have also tried the 6.2 version that is linked to in the .conf file) and copied the required 64-bit sqljdbc_auth.dll file to a folder in my path (c:\windows\system32 - I have tried many others)

However, I still cannot connect to the database using trusted security. When I run the .bat file using my credentials the web.log says “This driver is not configured for integrated authentication”. I know my account has access because I can connect from PowerShell perfectly and run sql commands.

Does anyone have any ideas please?

JDK is v11.0.10 (x64)
I have tried sqljdbc_6.2.2.1_enu.exe and sqljdbc_7.2.2.0_enu.exe

Thanks

Mark

Hey there.

This should help you!

Docs upddate is in progress :slight_smile:

Hi,

I have tried this and I still get the same error.
I have extracted the 9.2 JDBC driver zip file to c:\Program Files\Microsoft JDBC Driver 9.2 for SQL Server and copied the “mssql-jdbc_auth-9.2.1.x64.dll” file into “c:\windows\system32” (which is in the path) and I still get the error:

Caused by: java.lang.IllegalStateException: Can not connect to database. Please check connectivity and settings (see the properties prefixed by ‘sonar.jdbc.’).
Caused by: java.sql.SQLException: Cannot create PoolableConnectionFactory (This driver is not configured for integrated authentication. ClientConnectionId:9fd378b5-1267-424b-8863-15834afb5119)
Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: This driver is not configured for integrated authentication. ClientConnectionId:9fd378b5-1267-424b-8863-15834afb5119
Caused by: java.lang.UnsatisfiedLinkError: no mssql-jdbc_auth-9.2.0.x64 in java.library.path: [C:\Program Files\Java\jdk-11.0.10\bin, C:\Windows\Sun\Java\bin, C:\Windows\system32, C:\Windows, C:\Program Files\Common Files\Oracle\Java\javapath, C:\Windows\system32, C:\Windows, C:\Windows\System32\Wbem, C:\Windows\System32\WindowsPowerShell\v1.0, C:\Program Files\Microsoft\Web Platform Installer, .]

Hang on - user error. I used 9.2.1 and not 9.2.0 as suggested.

9.2.0 is working now! Thanks :slight_smile:

@MarkJEverest Great! And, as promised, docs are being updated.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.