T-SQL Project - Project now empty

All of a sudden one of our T-SQL projects is appearing empty. I have added verbose mode to the analysis and it seems it doesn’t associate the .sql files with any scanner:

09:41:56.986 DEBUG: 'RptSchedule\RptSchedule\dbo\Tables\Report_Schedule.sql' indexed with language 'null'
09:41:56.986 DEBUG: 'RptSchedule\RptSchedule\dbo\Tables\Schedule_Recipients.sql' indexed with language 'null'
09:41:56.986 DEBUG: 'RptSchedule\RptSchedule\dbo\Tables\Schedule_Report_List.sql' indexed with language 'null'
09:41:59.611 DEBUG: 'T-SQL Sensor' skipped because there is no related file in current project

We are using SonarCloud and run our analysis through the Azure DevOps pipelines.

Any help would be appreciated.

Thanks,
Pete

Hey Pete,

What’s the sonar.tsql.file.suffixes setting like for this project? does it include .sql?

This would either be in a local configuration file for your project, set on the command line or (most likely) set under Administration > T-SQL

Colin

Hi @ColinHMueller,

I’ve just had another look at it and it seems that all the suffixes were on one line in the SonarCloud Admin for the project! So just 1 entry with the value of ‘.tsql,.sql,sql’

I have set this back to 3 separate lines and it seems to be working again now. Is there an audit log for the Admin section, so we can investigate how this happened?

Thanks,
Pete