Source files ignored all of a sudden with the message excluded by the scm ignore settings

Hi,

Currently using SonarQube Developer Edition 9.6.1.59531 on C++ code with Azure DevOps integration.

We noticed on current scans that all of our C++ source files are being ignored. The following log entry is now referencing every single one of our source files where xxxxxxxx is the source filename.

2022-10-03T18:14:23.0106364Z 18:14:23.005 DEBUG: File ‘xxxxxxxx’ is excluded by the scm ignore settings.

Past scans worked without issues. Another post with a similar issue indicated negation patterns in their .gitignore file were the issue; however, our .gitignore file has not changed during the time the issue arised. As a test, we performed a scan without a .gitignore file and still encountered the same issue.

We also tried enabling the setting Disable the SCM Sensor". Our source files were then being analyzed but then the analysis failed to publish because it complained about exceeding our license limit of 100K LOC. The license error makes no sense because our last successful scan was only about 1700 LOC and our small development does not have the capacity to check in 100K LOC within a 1 day timeframe.

Any ideas on how to further troubleshoot or what the root cause may be?

Thanks

Hi,
Did anything changed in SonarQube (like an upgrade) that might have caused the different behavior regarding loading ignored files from the SCM?
There’s currently no known bug affecting it. Any chance you could send the full logs?
Note that you can disable loading ignores without disabling all SCM features by setting sonar.scm.exclusions.disabled to true.