SonarCloud doesn't analyze my repository (No line of code)

Template for a good new topic, formatted with Markdown:

  • ALM used: Azure DevOps
  • CI system used: Azure DevOps
  • Languages of the repository: C#
  • Steps to reproduce
  • Potential workaround

My repository analysis was working well, however, all of a sudden, I’ve got a message saying that my branch has no line of codes.
I tried to create a new branch and it worked properly for few days then it stopped working again.

It is working fine since I toggled SCM configuration.
However I do not know if it is the problem solution or only a workaround.

Also, I’d love to know why it stopped working.

The idea to switch the SMC configuration came after I noticed this log:

219 files ignored because of scm ignore settings

Please, find the log attached.
SonarCloud Log.txt (73.5 KB)

Hi @filipibc - welcome to the community.

Could you explain what you mean by “toggled SCM configuration” please?
Do you mean changing the value of the sonar.scm.exclusions.disabled setting?

We changed the sonar.scm.disabled key to true for this specific project

Are the files that are not being analyzed also ignored by your source control system?

No, they are not.

My source control system are not ignoring those files, however, the SonarCloud were ignoring all my .cs (code) files.

There isn’t enough information in the logs to see what is happening. Could you provide verbose logs please? (set sonar.verbose=true in the Advanced, Additional propeties section of the Prepare step)