Sonarqube takes forever to scan on Jenkins pipeline

Hello everyone.

I am currently getting to use Sonarqube with my pipeline. I have successfully installed sonarqube and worked on an Amazon-linux server. I also installed JFrog on same server since they use different ports. Now both worked separately when connected to the their respective consoles. The problem is when I set them up in Jenkinsfile to build a pipeline, once it gets to the stage where sonarque scans for artifacts, it takes forever to scan.
Could it be that JFrog and Sonarque can’t be on same server?

Hey there.

There’s no specific limitation here, but you should make sure that your server has the proper resources to handle both applications – I would start by checking how your server is doing (memory, CPU, disk).

The good news so far is that Jenkins can make the connection (it identifies that the server is 9.4), but it just trips up on making further API calls.

1 Like

The issue now is when I try to run code analysis with sonarqube on my local server, it get stucks at [INFO] Load metrics repository (done) | time=62ms

Okay. Have you checked this?

My server is running on Amazon Linux T2 Micro. 1vcpu and 0.5G memory

That’s probably way to small to be running two applications. The requirements documentation outlines the absolute minimum.

Hardware Requirements

  1. A small-scale (individual or small team) instance of the SonarQube server requires at least 2GB of RAM to run efficiently and 1GB of free RAM for the OS. If you are installing an instance for a large teams or Enterprise, please consider the additional recommendations below.

All is working fine now, thank you. Can you recommend a resource where I can learn deeper how to use Sonarqube?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.