Sonarqube suddenly stopped scanning

  • Using SonarQube Version 8.9.0.43852, Java version is 11.0.10
  • The scanner stopped scanning suddenly about 8 months ago, and just found out about it.
  • Tried upgrading, but the documentation is severely lacking. Looked through logs and tried to manually start a scan from command line. Getting the following error:
    09:26:06.369 The token you provided doesn’t have sufficient rights to check license.
    09:26:06.377 Pre-processing failed. Exit code: 1
  • The service is running as LocalSystem.
    I can’t seem to find a solution for this and we have an audit requirement to produce a report for the month of August.

Hi,

Welcome to the community!

My guess is that 8 months ago someone “cleaned up” permissions in SonarQube.

You should issue a new token from a user with analysis rights to the project(s) in question.

Note that in 9.6 (announced last week) you have the ability to issue limited permission, analysis-only tokens.

 
HTH,
Ann

Hi Ann. Thanks for the reply. I’ve tried issuing a new token and I get the same error. Also, I’m the only SonarQube administrator and I haven’t made any changes to permissions, unless you’re referring to OS level privileges. But the service is running as LocalSystem, so it should have the rights it needs to do the scans. I also attempted to upgrade, but the documentation for the free version isn’t that good.

Hi,

I’m sorry to hear that. It’s all the documentation there is. What do you feel is missing?

OS-level rights aren’t relevant here, just the permissions in SonarQube. And BTW, it’s quite possible to be a SonarQube global admin and not have analysis rights on a project. Since you are a global admin, can you check that you have ‘Execute Analysis’ either directly on the project in question or globally (Administration → Security → Global Permissions)?

 
Ann

Hi G Ann. I’ve tried modifying the Global permissions, but the scans are still not running. Do you have any other suggestions? Do I need to try to manually kick one off from command line?

Hi,

Based on the error message you provided, this is purely about project permissions. Can you try explicitly giving the token owner ‘Execute Analysis’ rights on the project(s) in question?

 
Ann