SonarQube setup stuck on loading when upgrading

We are in the process of upgrading from SonarQube Enterprise 7.5 to SonarQube Enterprise 7.7. We haven’t installed any additional plugins yet. We are having a problem getting /setup to do anything. It’s been “loading” for an hour and nothing. There is nothing in the logs to suggest anything. We are connecting through the reverse proxy, but again, I’m not seeing anything in the logs. I’m completely stumped and have no idea what to do at this point.

Just to double check, Is there really no sign of the database migration starting in the web.log file (same folder as sonar.log)

In the sonar.log it states that the database must be upgraded.

The last thing in the web.log after the ‘Deploy plugin’ list is the following:

2019.05.21 16:54:25 DEBUG web[o.s.c.i.DefaultI18n] Loaded 3000 properties from l10n bundles
2019.05.21 16:54:25 INFO web[o.s.s.p.d.m.c.PostgresCharsetHandler] Verify that database charset supports UTF8
2019.05.21 16:54:26 INFO web[o.s.s.p.Platform] Database needs migration
2019.05.21 16:54:36 WARN web[o.a.c.u.SessionIdGeneratorBase] Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [10,213] milliseconds.
2019.05.21 16:54:36 INFO web[o.s.s.p.w.MasterServletFilter] Initializing servlet filter org.sonar.server.ws.WebServiceFilter@76e1409d [pattern=UrlPattern{inclusions=[/api/system/migrate_db., …], exclusions=[/api/properties, …]}]
2019.05.21 16:54:36 DEBUG web[o.s.s.a.TomcatAccessLog] Tomcat is started
2019.05.21 16:54:36 INFO web[o.s.s.a.EmbeddedTomcat] HTTP connector enabled on port 9000
2019.05.21 16:54:53 DEBUG web[o.postgresql.Driver] Connecting with URL: jdbc:postgresql:///sonar?ssl=true
2019.05.21 16:54:53 DEBUG web[o.p.c.v.ConnectionFactoryImpl] Trying to establish a protocol version 3 connection to :5432
2019.05.21 16:54:53 DEBUG web[o.p.ssl.MakeSSL] converting regular socket connection to ssl
2019.05.21 16:54:53 DEBUG web[o.p.c.v.ConnectionFactoryImpl] Receive Buffer Size is 43,690
2019.05.21 16:54:53 DEBUG web[o.p.c.v.ConnectionFactoryImpl] Send Buffer Size is 9,900
2019.05.21 16:57:54 INFO web[o.s.p.StopWatcher] Stopping process

I should add that I did not install any additional plugins, so only the ones that come with SonarQube 7.7 Enterprise Edition are installed.

Should I give it more time? I’ve tried starting the process up a handful of times with the same result. If I recall correctly, there was always a button to click to begin the migration of the database. Did this change?

Hi,

In your case the database need indeed a migration, and that step is manual.

I agree that the log message is misleading and i opened a jira ticket to improve that message to be more specific about what need to be done : https://jira.sonarsource.com/browse/SONAR-12141

Please follow the documentation about migration : https://docs.sonarqube.org/latest/setup/upgrading/

You need to backup your database and browse to /setup to trigger manually the database migration. Until you do that, the server is not doing anything but waiting.

Hop its help !

The loading happens when I’m attempting to go to http://yourSonarQubeServerURL/setup to migrate the database, but I cannot get there. So I’m still stuck at the loading page and unable to migrate the database.

Indeed it seems that your server is stopped. Could you please report the last content of sonar.log and es.log ?

I think that is because I stopped it and switched back to the older version until I can get the newer version working.

I’ll try it again later today after everyone leaves and post the full logs.