SonarQube Saml SSO

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this

Set up SSO with Azure Active Directory
Tried the marketplace app all documents I can fond online and keep getting an error when trying to login via SAML. Below image is error I am receiving.

the response was received at “Company URL with Port” instead of “Company URL with saml authentication”



Anything interesting in your server logs? You may need to bump your log level up to get anything relevant.


I am seeing the same error in the debug logs as well as this


Can you try bumping your logging level up some to see if you get any more detail? Because what you’re showing simply says your authentication is failing & there’s not much I can help with on that.


Here is what I see with TRACE logs enabled


We’re not SAML experts, but this looks like a configuration error. I would walk back through the configuration on both sides & see where badURL is used instead of goodURL.


I have done that multiple times. Deleted everything and restarted with SAML. I think the issue is that I have a redirect Rule set up on the IIS site, which I have to have in order for HTTPS to work.

1 Like