Issues with SAML SSO Setup

We just recently stood up SonarQube Developer Edition Version 9.8. We are trying to set up SAML SSO to Azure AD but are running into issues. Here is what we have configured so far:

When we click the Test Configuration button, we get the following error:


I’ve turned on DEBUG logging for the web.log and captured the SAML-specific entries. I don’t see any errors but only see one entry for SAML (log below).

Also worth noting that when I click on the Log in with SAML button on the login page, it attempts to login with a Loading page and then just comes back to the Log in with SAML button. We have double/triple checked all the settings in the IIS reverse proxy and Azure AD/SAML configuration. Are there other configurations that are needed to get this to work?


Welcome to the community!

That suggests to me a misconfiguration. Per the docs:

verify that the configuration is correct by clicking on Test Configuration . A SAML login will be initiated and useful information about the SAML response obtained from the Identity provider will be returned.

You should double-check your IDP settings.


After much searching through the community, this is what did it for me. This should be put in the main SonarQube documentation.


Hi @ChristopherMank,

Thanks for linking this together; your reply helped us cross-connect a few threads that will contribute to an improvement and formalization of Colin’s Community guide into a new docs article!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.