Sonarqube is not showing coverage for the new branches

My issue is simple. I ran the gradle command

./gradlew jacocoTestReport sonarqube ${sonarOptions}

In the sonar project, I can see the code coverage for the master branch but when I switch the branch I can’t see the code coverage.

What I am missing?

Hello @Vikas_Rathore ,

Welcome to the community!

Did you already re-run the analysis for those other branches after you have made the changes to the Gradle command? If your project is public you could post a link here so that we can take a look at the configuration.

1 Like

Hi Martin, Thank you for helping.

Yes, I ran multiple times and I can see the coverage for the master but not for any other branches(PR branches).

It’s not a public repo. I am trying to implement the sonarqube to all our existing private repos.

What are all configurations do I need to see for this type of issue?

Any inputs. I am kind of stuck here.

I posted the same on stackoverflow but no help

@Vikas_Rathore just to clarify and find the right people to help: are you using SonarCloud or SonarQube?

@Martin_Bednorz I am using sonarqube. I can see the code coverage on my main branch(develop) but not on other branches.

Also, I am getting this warning, not sure if this was relevant to my issue.