SonarQube Community Edition Database change

I am evaluating the 8.4 community edition of Sonarqube.

Initially I was using the embedded database but I then updated the file to use a MSSQL Database that I had created.

The SonarQube server will start ok but when I go to create a project following the database change I get an error
“Main branch in Project not found.”

Any help here will be greatly appreciated


Welcome to the community!

How are you trying to create a project?


I am creating the project manually from the UI.

I get as far as giving it a project name etc. I get the error on the page where I would expect to be asked for a token


How about a screenshot?

…And maybe check your browser console for errors?


Could it be database related.
Its working fine when I was using the embedded one,


Shouldn’t be. Anything DB-related would show up at start up. You get an interface that paints, so that indicates the DB is fine.


If I select configure analysis (screenshot)

I get this error

I am evaluating 8.5 community edition of Sonarqube.

I have created the database on MSSQL (using integrated authentication) and when I started the server for the first and tried to connect with the WEB ui I could see a number of tables being created.
However when I manually try to create a project I only get as far as giving it a project name.
After that point I get this error:

I have traced the error down further.

When I create a new project an entry is being added to the dbo.projects table however there should also be a row added to the dbo.projects_branches table.

This row isnt being added, which is why the project not found error is being displayed on the next page.

Why would the table not be populating correctly

Hi @Declan11,

Welcome to the community.

Could you please state more information about your MSSQL instance?

  1. Which version are you running? Manual instance or docker one for example?
  2. On which operating system?
  3. Could you explain a bit more what you’re referring to by integrated authentication?


By integrated authentication, I am talking about connecting using my windows account rather than an MSSQL user account,

Thanks for the information.

Please make sure you’ve read this documentation page, especially the MS SQL Server section.

If this still doesn’t help, I see 2 interesting things to gather now:

  1. Logs of SonarQube when running for the first time against the new MSSQL database
  2. Logs of SonarQube when creating a new project

Please enable the debug level of logs. See this documentation page for more information.