Sonarqube 9.8.0-community docker image doesn't work


I’m trying to use the docker image of Sonarqube 9.8.0 community edition but It doesn’t work.
In the web interface, after the loggin, I always get a white(blank) page.
As follow are reported details about Sonarqube and procedure used.

#Sonarqube Version

  • I’m using the image tagged as 9.8.0-community (from link

#Procedure used to run docker image
In order to run docker image I executed the following steps:

  • step#1: environment preparation (from link Docker):

    • sysctl -w vm.max_map_count=524288
    • sysctl -w fs.file-max=131072
    • ulimit -n 131072
    • ulimit -u 8192
  • step#2: pull immage

    • docker pull sonarqube:9.8.0-community
  • step#3: volume creation:

    • docker volume create --name sonarqube_data
    • docker volume create --name sonarqube_logs
    • docker volume create --name sonarqube_extensions
  • step#4: run command:

  - docker run -d --name sonarqube \
    -p 9000:9000 \
    -v sonarqube_data:/opt/sonarqube/data \
    -v sonarqube_extensions:/opt/sonarqube/extensions \
    -v sonarqube_logs:/opt/sonarqube/logs \

#Problem description:
step#1 to step#5 are ok; in step #5 after first login I successfully changed the admin password; but after with first login (with changed password) I get a blank page. I tried to stop and restart the docker image but, after login as admin, I
always get a blank/white page.
Could You help me to solve the problem?
Thanks in advance.

Hello @giusebera , welcome to the Community!

I have just tried the exact same steps you describe and haven’t faced any issue.

Have you checked your browser’s Developer Tools? Are there any messages in the Console tab? Any request errors in the Network tab?

What about the Docker container log? Any error in the output of docker logs sonarqube?


Hi David,
thanks for your support.
I followed your instructions:
Developers Tools → Network tab
After a successfully logged in, in the Network tab of Chome (Chromium browser - version 73.0.3683.0 64 bit), in the list of actions I get all HTTP Status to 200(=OK) but a new tab errors appears and it presents the following errors:

react-dom.production.min.js:209 TypeError: o.replaceAll is not a function
    at l10n.ts:46
    at Array.reduce (<anonymous>)
    at O (l10n.ts:46)
    at cyr (GlobalFooter.tsx:58)
    at Vpe (react-dom.production.min.js:153)
    at xje (react-dom.production.min.js:261)
    at Sje (react-dom.production.min.js:246)
    at R9t (react-dom.production.min.js:246)
    at ipe (react-dom.production.min.js:239)
    at react-dom.production.min.js:123
epe @ react-dom.production.min.js:209
e.callback @ react-dom.production.min.js:226
u5e @ react-dom.production.min.js:131
_9t @ react-dom.production.min.js:212
A9t @ react-dom.production.min.js:255
ii.unstable_runWithPriority @ scheduler.production.min.js:19
Vk @ react-dom.production.min.js:122
BR @ react-dom.production.min.js:248
ipe @ react-dom.production.min.js:239
(anonymous) @ react-dom.production.min.js:123
ii.unstable_runWithPriority @ scheduler.production.min.js:19
Vk @ react-dom.production.min.js:122
q4e @ react-dom.production.min.js:123
rC @ react-dom.production.min.js:122
D9t @ react-dom.production.min.js:257
ii.unstable_runWithPriority @ scheduler.production.min.js:19
Vk @ react-dom.production.min.js:122
_2 @ react-dom.production.min.js:257
(anonymous) @ react-dom.production.min.js:256
iue @ scheduler.production.min.js:17
tue.port1.onmessage @ scheduler.production.min.js:14
l10n.ts:46 Uncaught TypeError: o.replaceAll is not a function
    at l10n.ts:46
    at Array.reduce (<anonymous>)
    at O (l10n.ts:46)
    at cyr (GlobalFooter.tsx:58)
    at Vpe (react-dom.production.min.js:153)
    at xje (react-dom.production.min.js:261)
    at Sje (react-dom.production.min.js:246)
    at R9t (react-dom.production.min.js:246)
    at ipe (react-dom.production.min.js:239)
    at react-dom.production.min.js:123

I tried to use Mozilla Firefox as browser but I get the same result. I attached a snapshot with Crome-Developer Tools where are shown the results (HttpStatus and errors).

Sonarqube log
In sonarqube logs no errors are shown; below I report a snippet but I attached the complete log file:

2023.01.06 20:26:04 INFO  ce[][o.s.p.ProcessEntryPoint] Starting Compute Engine
2023.01.06 20:26:04 INFO  ce[][] Compute Engine starting up...
2023.01.06 20:26:04 INFO  ce[][o.sonar.db.Database] Create JDBC data source for jdbc:h2:tcp://;NON_KEYWORDS=VALUE
2023.01.06 20:26:04 INFO  ce[][c.z.h.HikariDataSource] HikariPool-1 - Starting...
2023.01.06 20:26:05 INFO  ce[][c.z.h.p.HikariPool] HikariPool-1 - Added connection conn0: url=jdbc:h2:tcp:// user=
2023.01.06 20:26:05 INFO  ce[][c.z.h.HikariDataSource] HikariPool-1 - Start completed.
2023.01.06 20:26:05 WARN  ce[][o.s.db.dialect.H2] H2 database should be used for evaluation purpose only.
2023.01.06 20:26:06 INFO  ce[][o.s.s.p.ServerFileSystemImpl] SonarQube home: /opt/sonarqube
2023.01.06 20:26:06 INFO  ce[][o.s.c.c.CePluginRepository] Load plugins
2023.01.06 20:26:08 INFO  ce[][o.s.c.c.ComputeEngineContainerImpl] Running Community edition
2023.01.06 20:26:08 INFO  ce[][] Compute Engine is started
2023.01.06 20:26:08 INFO  app[][o.s.a.SchedulerImpl] Process[ce] is up
2023.01.06 20:26:08 INFO  app[][o.s.a.SchedulerImpl] SonarQube is operational

sonarqube.log (75.0 KB)

In any case, the INFO LOGS only show that the process is running; to see what happens before/during/after the login process how can i set the logs to DEBUG or TRACE? Could you please tell me how I can change the logging level?

Thanks in advance
Best Regards

Hi Giuseppe,

thanks for the details. I believe the issue comes from the fact that we use code that is only compatible with Chrome versions >=85 (Aug 2020), or Firefox >=77 (May 2020), and you’ve used Chromium 73 (Jan 2019), and what I suppose is Firefox < 77.

While we fix this compatibility issue on our end, if you’re able to use more recent browser versions, could you please try again with Chrome >=85 or Firefox >=77 and tell us if this resolves the issue you faced?

Thanks for your patience.

Hi David,

With your hint, now after a login, the dashboard is visible.

In details, I updated Chomium to the latest available version (111.0.5525.0 - 64 bit) and Sonarqube dashboard is visible.

Since it’s my first time using sonarqube; I read that it would be useful for Elisticsearch to change the DB from H2 to a DBMS; could you give me instructions to use sonarube with postgresql as DB?

Thanks a lot for your support,


Hi Giuseppe,

glad the browser update fixed your initial problem.

For PostgreSQL, have you checked the SonarQube documentation?

Hi Giuseppe, just FYI - not necessarily useful for you, now you’ve upgraded, but could be useful to other users with older browsers - we’ve opened a bug ticket on SonarQube to make sure we support older browsers again.

Hi David,

Thanks a lot; You are the best.

Now I’m trying to use Sonarqube in CLI modality (with maven). Next step is to use Sonar in Jenkins.

Best regards

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.