7.9.3 docker instance won't start

sonarqube v7.9.3 community edition
OS: CentOS 7
DB: default H2

Rough DockerFile logic

  1. From CentOS 7 image
  2. download sonarqube
  3. entry point run.sh

run.sh

  1. exec java -jar lib/sonar-application-"${SONAR_VERSION}".jar
    -Dsonar.log.level=“DEBUG”
    -Dsonar.log.console=“true”

The container dies with attached log file.

I tried setting following properties but it failed due to read only file system:

sysctl -w vm.max_map_count=262144
sysctl -w fs.file-max=65536
ulimit -n 65536
ulimit -u 4096

I tried -Dsonar.search.javaAdditionalOpts=" -Dnode.store.allow_mmapfs=false" without success. When I ran the java startup cmd directly from host, it works fine but inside docker it failed.sonar_console.txt (18.3 KB)

Hi @piyushml20,
The logs you’ve posted don’t really show the cause, you should have a look inside ${SONAR_DIR}/logs/es.log which content seems to not be printed to the log file you provided. You can check if you are running into the same problem with our SonarQube image.

Thanks Michal, the issue was due to my configuration. I allocated less resources and hence, container was getting evicted.