Unable to start the docker container 8.9.0-enterprise version

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) - Docker image 8.9.0-enterprise
  • what are you trying to achieve - Run the Docker container of the 8.9.0-enterprise version
  • what have you tried so far to achieve this - I have tried to start the docker container but the container stops with the below error. However, the 8.8.0-enterprise version starts up successfully.

2021.05.19 14:43:33 WARN app[][o.s.a.p.AbstractManagedProcess] Process exited with exit value [es]: 137


% docker run -ti --env SONAR_CE_JAVAOPTS="-Xmx1G -Xms1G" -p 9000:9000 sonarqube:8.9.0-enterprise

2021.05.19 14:43:29 INFO app[][o.s.a.AppFileSystem] Cleaning or creating temp directory /opt/sonarqube/temp

2021.05.19 14:43:29 INFO app[][o.s.a.es.EsSettings] Elasticsearch listening on [HTTP:, TCP:]

2021.05.19 14:43:29 INFO app[][o.s.a.ProcessLauncherImpl] Launch process[[key=‘es’, ipcIndex=1, logFilenamePrefix=es]] from [/opt/sonarqube/elasticsearch]: /opt/sonarqube/elasticsearch/bin/elasticsearch

warning: usage of JAVA_HOME is deprecated, use ES_JAVA_HOME

2021.05.19 14:43:30 INFO app[][o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running

warning: no-jdk distributions that do not bundle a JDK are deprecated and will be removed in a future release

OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.

2021.05.19 14:43:33 WARN app[][o.s.a.p.AbstractManagedProcess] Process exited with exit value [es]: 137

2021.05.19 14:43:33 INFO app[][o.s.a.SchedulerImpl] Process[es] is stopped

2021.05.19 14:43:33 INFO app[][o.s.a.SchedulerImpl] SonarQube is stopped

Hey there.

This tells us that more information about the warning will be found in your /logs/es.log file of the SonarQube installation directory in the container.

And, please don’t tag individuals not participating on a thread.

I was having a similar issue and the es.log wasn’t very useful.

Increasing the runtime memory for the container using using the docker -m or --memory flag fixed my issue.


@Preet Thank you for the update. I had solved it by increasing the memory of docker on my mac.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.