Sonarqube container latest does not start

Hi,
I’m trying to run a docker container with the tag latest:
docker run -d --name sonarqube -e SONAR_ES_BOOTSTRAP_CHECKS_DISABLE=true -p 9000:9000 sonarqube:latest
as it is described in the Try out sonarqube page Try Out SonarQube | SonarQube Docs
But the container does not start, the logs I see :

2021.07.15 10:28:44 INFO app[o.s.a.AppFileSystem] Cleaning or creating temp directory /opt/sonarqube/temp
2021.07.15 10:28:44 INFO app[o.s.a.es.EsSettings] Elasticsearch listening on [HTTP: 127.0.0.1:9001, TCP: 127.0.0.1:40331]
2021.07.15 10:28:45 INFO app[o.s.a.ProcessLauncherImpl] Launch process[[key=‘es’, ipcIndex=1, logFilenamePrefix=es]] from [/opt/sonarqube/elasticsearch]: /opt/sonarqube/elasticsearch/bin/elasticsearch
2021.07.15 10:28:45 INFO app[o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
could not find java in ES_JAVA_HOME at /opt/java/openjdk/bin/java
2021.07.15 10:28:45 WARN app[o.s.a.p.AbstractManagedProcess] Process exited with exit value [es]: 1
2021.07.15 10:28:45 INFO app[o.s.a.SchedulerImpl] Process[es] is stopped
2021.07.15 10:28:45 INFO app[o.s.a.SchedulerImpl] SonarQube is stopped

1 Like

Hello @Razvan_Bugariu and welcome to the community :wave:

you are probably impacted by SONAR-15167. try to upgrade your docker installation or if this not an option for you to change the default action in your seccomp-profile (line 2) to return SCMP_ACT_TRACE instead of SCMP_ACT_ERRNO.
you can also use this seccomp profile just for sonarqube if you adapt the run command like this:

docker run -d --name sonarqube --security-opt seccomp=/path/to/your/seccomp_profile.json  -e SONAR_ES_BOOTSTRAP_CHECKS_DISABLE=true -p 9000:9000 sonarqube:latest

hope that helps :slight_smile:

3 Likes

Thanks for the replay!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.