SonarCloud Quality Gate in infinte waiting status on Azure DevOps PR

Follow up on

As mentioned in the post, everything was working perfectly. On Monday June 7th 2021 we started to have issue in SonarCloud with “Analysis in Progress, This can take up to 30 mins”. This part seems to be solve now.

Now:
We can see the status in the extension in the builds:
Snap 2021-06-10 at 10.40.21

We do not get the status back to Azure DevOps Required Checks (policies), thus blocking all PR for completion.
Snap 2021-06-10 at 10.30.27

Issues is the same on all repos
ADO PAT have been updated (though not expired)

Example of analysis: AXn0t97JbUEpB7CjlHd7

cc: @Marcin_Majewski @mickaelcaro @bsegault

Hello,

It looks like you organization is bound to Azure, but the project is created manually and I do not see that the token or provider is set. If the project is created manually you have to set the provider and the token on the project level. You can do it in the Admininistration → Pull Requests.

Is the issue consistent on all the repos or only the ones that are not bound? (not bound are the ones without Azure DevOps logo next to the name)

Best,
Marcin

Great, update the token, I it seems to work good now.
How do we import the project directly from ADO so we can use the global access token or how do we setup existing projects to use the global access token instead of having to go to each project and update it?
Thank you!
Alex

Hey @alhugot-emr,

Currently, the only way to make the project bound is to import it from the list of available projects, like this:


And select the project from the list:

When the project is imported like that, the token is taken from the global organization setting (no need to set up the token on the project level)

Unfortunately, there is currently no way to migrate an unbound project to a bound one (although there will be work done on that matter, but I cannot promise any date). So if you would like to convert the manually created projects to bound ones, it would mean deleting the manual one and reimporting in the recommended way (this would of course mean, losing history, etc.)

Best,
Marcin

Geat, thank you very much for your help!
Alex

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.