Sonar SAML Authentication issue with okta on 8.4 and above

Hey there, we are trying to deploy and run sonarqube 8.4 with saml integration ( w okta ) and we are running into an error

The response was received at http://sonar.url/oauth2/callback/saml instead of https://sonar.url/oauth2/callback/saml

The same configuration works on 8.3.

How and where is sonarqube deployed:

image:
  tag: 8.4-enterprise
ingress:
  enabled: true
  annotations:
    kubernetes.io/ingress.class: <nginx-ingress-controller>
  hosts:
  - name: sonar.url
    path: /
sonarProperties:
  sonar.auth.saml.enabled: true
  sonar.auth.saml.applicationId: sonarqube
  sonar.auth.saml.providerName: <ProviderNameFromOkta>
  sonar.auth.saml.providerId: http://okta.url/<providerID>
  sonar.auth.saml.loginUrl: https://okta.url/sso/saml
  sonar.auth.saml.user.login: login
  sonar.auth.saml.user.name: name
  sonar.auth.saml.user.email: email
  sonar.auth.saml.group.name: groups
  sonar.auth.saml.certificate.secured: <CERT>
  sonar.core.serverBaseURL: https://sonar.url

Hi,

Welcome to the community!

First, 8.4 is past EOL. You should upgrade to 8.9 - the LTS and currently the Latest version - at your earliest convenience.

Second, there were some changes to SAML in 8.4. Since your error seems to be about http vs https, this thread might be helpful:

 
Ann