Sonar Lint slows IntelliJ and doesn't apply rules when bounded to SonarQube after few minutes

  • Operating system: macOS Monterey version 12.6
  • SonarLint plugin version:
  • Programming language you’re coding in: typescript
  • Node version - Node.js v18.10.0 (using nvm)
  • Is connected mode used: yes
    • Connected to SonarQube Version 8.9.8

And a thorough description of the problem / question:

Issue: sonarLint don’t show lint errors after few minutes (say 5minutes) of opening the IntelliJ and then the sonarLint is auto-enabled.

When I see the logs in the beginning it shows below and able to show the sonar lint errors.

starting eslint-bridge server at port 63685
eslint-bridge server is running at port 63685
Starting server (done) | time=3761ms

After few minutes it shows below

Skipping the start of eslint-bridge server as it failed to start during the first analysis or it’s not answering anymore
No rules will be executed
Hit the cache for 0 out of 0
Miss the cache for 0 out of 0

At this point IntellIJ hangs and even scrolling through file takes time. I’m suspecting this due to the memory usage ( I’m assuming this because when I view the sonarlint dumps in /Users/MAC_USER/Library/Caches/JetBrains/IntelliJIdea2021.2/tmp/sonarlint I observe bunch of sonarlint files with around 150MB each.)

. please correct me if I’m missing something and let me know if you have experienced this before.

Thank you.

Sonar IntelliJ platform please do reply

Hi @arvind, I am very sorry for the late reply. For some reason, this thread went under our radar.

If you still encounter the issue with the latest version of SonarLint, I would like to try to investigate it with you.

I have a similar problem with one of our large projects.
It works for a little bit and then stops working until restarting the IDE.
The issue for me is it is running out of memory, however when I add to my file
it doesn’t take effect.
The logs still show

Running in SonarLint context, metrics will not be computed.
Using Node.js executable C:\Program Files\nodejs\node.exe from property sonar.nodejs.executable.
Checking Node.js version
Launching command C:\Program Files\nodejs\node.exe -v
Using Node.js v16.19.1.
Launching command C:\Program Files\nodejs\node.exe C:\Users\me\AppData\Local\JetBrains\WebStorm2023.2\tmp\sonarlint\.sonarlinttmp_14988807921629517294\bridge-bundle\package\bin\server 55353 C:\myproject true true false 
Memory configuration: OS (65458 MB), Node.js (4144 MB).
Starting the bridge server
The bridge server is listening on port 55353
The worker thread is running
Starting heartbeat service
Starting server (done) | time=3092ms

Is the sonar.javascript.node.maxspace config option still being used by SonarLint?
Might there be something else stopping it from starting node with my specified memory limit?

My system details are:

  • Windows 10 pro (build 19045)
  • WebStorm 2023.2.5
  • WebStorm SonarLint plugin
  • Node.js v16.19.1

Actually I got the setting to work. I just had to set it in the SonarLint plugin settings in the IDE, not in the file.


Hi @rooby,

Thanks for sharing this with us. We’ve updated the SonarLint docs to explain how to address this memory issue. See Troubleshooting - IntelliJ.

Best regards,


1 Like