Skipping text document analysis because workspace folder is not synchronized yet

Please provide

  • Operating system: Windows 11
  • SonarLint plugin version: v4.4.1
  • Programming language you’re coding in: Typescript / Node.js
  • Is connected mode used:
    • Connected to SonarQube (and which version): Community Edition Version 10.4 (build 87286)

And a thorough description of the problem / question:

When I try to connect SonarLint with SonarQube, and bind project, i see in output console from VSCode this message : [Info - 18:47:07.757] Skipping text document analysis because workspace folder is not synchronized yet “-filename-”.

This message appears every time I open or edit a file, and therefore, no issues are displayed on vscode while there are dozens on sonarQube.
A priori, there is no other error, the project seems correctly bound, the key is correct, the synchronization of the rules seems correct too.
I tried uninstalling and reinstalling sonarLint, removing the connection with SonarQube and re-creating it, restarted VSCode, updated everything, nothing changes.

Now, I uninstalled again SonarLint, removed all configuration relative to the extension from vscode, reinstalled SonarLint without change anything in the default configuration. I removed the “sonar-project.properties” of my project, and the linter wont work, and I have the same message in output console : “Skipping text document analysis because workspace folder is not synchronized yet”, again and again.

EDIT :

I noticed this: When I open the project folder A: SonarLint does not want to analyze the files in folder A (same error message), on the other hand if, on VSCode, I “open a file” coming from project B, then SonarLint will analyze it.
This behavior is identical when I open the folder of project B: No file is analyzed, and when I open a file from project A, then SonarLint wants to analyze this file.

Thanks for your help

3 Likes

Hi there @Gouttfi, welcome to Sonar Community! :sonar: :wave:

Thanks for the detailed description! I tried reproducing it on my side and while the project is synchronizing I also see the same log line about skipping analysis (which is expected), but after a few seconds once the sync is complete, analysis takes place and I can see issues as expected. :thinking:

Would you be able to provide full SonarLint logs as described here?

Any further details or hints on how to reproduce are more than welcome! :bowing_woman:

Thanks in advance,
Sophio

Thanks for your answer.

I restarted my computer, started vscode, and here is the logs, the problem is always the same.

Note : I anonymized certain information that I considered sensitive and replaced by common names : “hostname”, “my-project”, “filename.ts”, etc.

logs.txt (57.0 KB)

I don’t really know what else to say. Sonarqube is hosted by me and works correctly, the connection between sonarqube and vscode also seems correct. There are around a hundred issues that I have to process and which are reported correctly on SonarQube.
The only thing missing is that the information goes back to SonarLint.

Thank you for your help.

1 Like

Thanks a lot for the logs @Gouttfi! :bowing_woman:

Unfortunately, we don’t see anything clearly wrong there, and cannot reproduce the problem ourselves either. :frowning: Early next week we will be able to share with you a pre-release artifact of SonarLint for VSCode that will log more extensively the steps happening during project synchronization. We would really appreciate it if you could give it a try.

I will post the update in this thread. In the meantime, you might choose to keep using the previous version 4.3.

Sorry for the inconvenience and thanks again,
Sophio :slight_smile:

2 Likes

Hi Sophio,

I will wait for you to post the pre-release here.

Would you prefer that I don’t touch anything until then so that you might be able to find something in the more detailed logs? Even if I don’t have much idea what to do to resolve the situation, the only things I haven’t tried yet is to reinstall VSCode, or to test on another IDE.

Thank you ! :slight_smile:

I get the exact same issue using the VSCode SonarLint extension (v 4.4.1) analyzing Java files - the log output reads “Skipping text document analysis because workspace folder is not synchronized yet”.

I tried restarting VSCode, selecting different projects, reinstalling SonarLint, etc., all to no success. But downgrading to v 4.3 fixed the problem.

1 Like

Thanks for the report @Trollend :bowing_woman:

Would you be able to share SonarLint logs with us? From when the problem occurs - i.e. v4.4.1

Thanks in advance,
Sophio

“I also encountered the same problem when writing Python, it won’t analyze the files in the current folder, but it can for files in other folders. I have now downgraded to 4.3.0.”

1 Like

Thanks @wangquanqing! We would appreciate any further details you can share such as

  • Are you in Connected Mode? If so, is it with SonarQube (which version) or SonarCloud?
  • Which OS are you on?
  • Ideally, if you can also share some logs

Thanks in advance for your help and patience :bowing_woman:

All the best,
Sophio

I’m encountering the same error.

Windows 10
SonarCloud connected mode

I’ll list “unusual” things that come to mind about by setup that might be causing this bug:

  1. The workspace is located on a different drive than the OS and VS Code.
  2. I use git worktrees to be able to work on multiple copies of the project at once while sharing the same local git repository. The issue seems to happen even in the main worktree, though, which I wouldn’t expect to trip something up.
2 Likes

I’ve collected and somewhat redacted a log of the output from version 4.4.1 of the extension, exhibitng the issue:

log_4.4.1_redacted.txt (8.8 KB)

I don’t see anything in it that obviously indicates the source of the error. The following warnings are probably unrelated:

  1. Using ${workspaceFolder} variable in sonarlint.pathToCompileCommands is only supported for files in the workspace
    This warning also occurs with version 4.3.0, which works fine. Also, the log that Gouttfi uploaded doesn’t share this warning.
  2. Node.js could not be automatically detected, has to be configured manually in the SonarLint preferences!
    This warning did not occur with version 4.3.0, but I think this just means that JS and related language analyzers won’t work. These aren’t languages I work with. Also, the log that Gouttfi uploaded doesn’t share this warning.
2 Likes

Got same issue with C# *.cs files. MacOS, not connected to SonarCloud. I downgraded to v.4.3.0 and it goes away.

1 Like

Hello everyone, :wave:

Thanks for all your reports, logs, and patience :slight_smile: I am sharing the promised custom build with enhanced logging. If you would be so kind as to try it out and share the logs, it would help us a lot in preparing the bugfix release, as we still cannot reproduce the issue on our side.

HERE you will find the build for all available platforms. For even more enhanced logs, you can add the following line to your VSCode User Settings - "sonarlint.trace.server": "verbose". But don’t forget to remove it after collecting the logs, as it is really really verbose option :sweat_smile:

Thanks in advance for your help :bowing_woman:
All the best,
Sophio

To install the custom build, you will need to go to VSCode > Extensions > … > Install from VSIX

1 Like

The issue is still present for me with version 4.4.2+76186, although I believe that was expected.

I set "sonarlint.trace.server": "verbose" and the output is much more verbose, but there’s still nothing that jumps out to me as an indication of the issue. Excluding the server trace messages, the pattern of messages appears to be the same as it was with version 4.4.1.

Is there a way I can securely share the log file? The server trace messages include a lot of information, more than I’d like to have to review for sensitive information to redact.

1 Like

Is there a way I can securely share the log file?

Yes, absolutely! You can share it in a private message. I have started a conversation as you might not have the rights to do so.

Best,
Sophio

I have the same issue as well, with the latest version of VS Code and the SonarLint extension. I am not using Connected Mode.

I also tried different Wi-Fi networks and different projects, so it doesn’t seem to be related to connectivity neither project settings.

1 Like

Thanks for the report @hb20007, and welcome to the Community! :wave:

Please follow the instructions here and share the logs with us if you are able to do so :bowing_woman:

Also, which Operating System are you using, and which programming language do you want to analyze?

TIA,
Sophio

I am using Windows 11 and working with JS. However, I also tried creating a .java file in my project and I see the same issue, so it does not seem to be related to the programming language.

Regarding the logs, is it enough to add "sonarlint.trace.server": "verbose" to my settings, or do I need to download the custom build?

1 Like

Regarding the logs, is it enough to add "sonarlint.trace.server": "verbose" to my settings, or do I need to download the custom build?

Since you are in standalone mode (not connected), there is no need for the custom build. You can just follow the instructions here to enable verbose logging, and then also add the "sonarlint.trace.server": "verbose" to your User settings.

All the best,
Sophio