Regular expression in project permission templates

Hi all. i am new to the forum.
I have searched the forum for solutions regarding reg.expressions in the projects permission template, but so far I haven’t found what I am looking for.

I am using SonarCloud in a private organization.
All projects are private.

I have created a permission template with the following regular expression: Jj][Uu][Ss][Tt].[Tt][Ee][Ss][Tt].*

When i create a new project with the project key JUST.TEST.My01stTest the permission template is not implemented.

Any ideas why is that?
I have verified the reg-exp using and I get a hit.
Is it because I use a private organization?
Because the project is private?
Error in the reg.exp?

Thanks :slight_smile:


Welcome to the community!

I just tried this with [Jj][Uu][Ss][Tt].[Tt][Ee][Ss][Tt].* as the regex

And JUST.TEST.My01stTest as the project key, and it worked for me:

Perhaps you have some stray whitespace or unexpected character in there somewhere?


Hi Ann.
Thanks for the quick response :slight_smile:
I think I got what the problem is:
The regular expression you have used, does work. It’s just not the one I have tried to describe…
Mine was this:

But for some reason, in the chat, it got changed to [Jj][Uu][Ss][Tt].[Tt][Ee][Ss][Tt].*

However- now I have something that works :smiley:



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.