Qualtiy Profile Rules Dissapeared Post Upgrade

Sonar Way Rules got disabled post upgrade from 7.1 to 7.9 for all languages.
This is resulting showing zero code bugs and code smells.
On selecting any quality profile shows zero rules enabled.
Is there a way to reload/enable the rules in SonarWay Quality Profile.

Hi,

Welcome to the community!

It sounds like somehow your new instance is missing all its analyzer plugins…? Check $SONARQUBE-HOME/extensions/plugins.

 
HTH,
Ann

1 Like

Hi Ann,
I am currently using the plugins in the manner that I download the ones that I need.
Could this be a compatibility issue. I am using Sonarqube Version 7.9.1 Community Edition.
Do you think, this could have resulted in disabling the rules.

The plugins that I am currently using , and are part of $SONARQUBE-HOME/extensions/plugins
are:

sonar-auth-gitlab-plugin-1.3.2.jar
sonar-c-plugin-1.2.2.1653.jar
sonar-csharp-plugin-7.14.0.8411.jar
sonar-cxx-plugin-1.2.2.1653.jar
sonar-findbugs-plugin-3.10.0.jar
sonar-go-plugin-1.1.1.2000.jar
sonar-jacoco-plugin-1.0.1.143.jar
sonar-perl-plugin-0.4.5-all.jar
sonar-php-plugin-3.0.0.4537.jar
sonar-plsql-open-plugin-2.2.0.jar
sonar-python-plugin-1.13.0.2922.jar
sonar-scala_2.12-7.5.0-assembly.jar
sonar-shellcheck-plugin-2.0.0.jar
sonar-typescript-plugin-1.9.0.3766.jar

Hi,

So… what rules are missing? Missing from where? Screenshot(s)?

 
Ann

The default profile sonarway for all languages is showing zero rules enabled. The screen shot is an example of Java Sonar Way Profile

Hi,

You’re showing me a screenshot of the Java Sonar way. But it seems that you’ve removed the Java analyzer from your instance…?

 
Ann

Hi Ann,
You meant sonar-java plugin is missing in the plugins directory. Right ?
As of now the default sonarway profile for all languages is showing me zero rules enabled.
I have added an example for sonarway go profile, but the plugin is present in the directory structure.
Yes you are right. I am downloading the plugins mentioned below, after cleaning up the directory content of
$SONARQUBE-HOME/extensions/plugins .

sonar-auth-gitlab-plugin-1.3.2.jar
sonar-c-plugin-1.2.2.1653.jar
sonar-csharp-plugin-7.14.0.8411.jar
sonar-cxx-plugin-1.2.2.1653.jar
sonar-findbugs-plugin-3.10.0.jar
sonar-go-plugin-1.1.1.2000.jar
sonar-jacoco-plugin-1.0.1.143.jar
sonar-perl-plugin-0.4.5-all.jar
sonar-php-plugin-3.0.0.4537.jar
sonar-plsql-open-plugin-2.2.0.jar
sonar-python-plugin-1.13.0.2922.jar
sonar-scala_2.12-7.5.0-assembly.jar
sonar-shellcheck-plugin-2.0.0.jar
sonar-typescript-plugin-1.9.0.3766.jar

Can you please advise, on how can this be fixed.

Hi,

At this point I’m guessing your ES indices are corrupt, so I think it’s time to:

  • stop the server
  • delete $SONARQUBE-HOME/data/es6
  • restart the server

 
HTH,
Ann

1 Like

Hi Ann , Really appreciate your advise. I was able to see all the rules again, after deleting ES6/data, and restarting SonarQube Server

1 Like