Pull Request Decoration GIT + Teamcity

Dear Experts,
Here is my setup with the tools and it’s version
Sonar Cube Version : Enterprise Edition Version 7.9.2 (build 30863)
GIT: GitHub Enterprise Server 2.21.6
Teamcity : TeamCity Enterprise 10.0.4 (build 42538)

There is lot of information about PR Decorations available over internet but I am finding it very difficult to make it work with Teamcity.
It would be really nice if someone help me with the right information which works for these versions

Kind Regards

Hi Bharat,

Welcome to the community!

Can you tell us

  • what steps you’ve taken
  • what you’ve tried
  • what the results were



Apologies Ann for late response.
To be honest with you I am not able to find simple documentation which is step by step to configure
GIT, Teamcity, & Sonar with above version.

With my limited knowledge here is what i did.
In teamcity I have a SonarQube Runner available as a runner
I have configured sonar server
With server url, JDBC URL & user credentials

I get below error
[08:07:23] [Step 1/1] ERROR: Error during Sonar runner execution
[08:07:23] [Step 1/1] INFO: ------------------------------------------------------------------------
[08:07:23] [Step 1/1] ERROR: Fail to download libraries from server
[08:07:23] [Step 1/1] ERROR: Caused by: 1
[08:07:23] [Step 1/1] ERROR:

[08:07:23] [Step 1/1] ERROR: To see the full stack trace of the errors, re-run SonarQube Runner with the -e switch.

I would appreciate if someone can help me with simple steps of what to do in teamcity, what to do in sonar and what to do in git to make these decoration to work.
PR decorations are one of the wonderful thing and I wan my whole organization to them.

Kind Regards

Hi Bharat,

I can’t speak to BitBucket but I can give you a hint on this analysis error. One of the first things analysis does is reach out to the server to get some information. What we see in your error is that initial call is failing. Did you configure the location of the SonarQube server somewhere in TeamCity? Did you pass it on the analysis command line (-Dsonar.host.url=[SonarQube url])?


Dear Ann,
Thanks for your quick response.
In the mean time I followed another documentation

However, when I try to follow the below step

Setting your global settings

To set your global settings in SonarQube, navigate to Administration > Configuration > General Settings > ALM Integrations and select the GitHub tab.
I don;t see these menu options in my sonarcube

Can you throw some light on this.
Kind Regards

Hi Bharat,

You’re looking at documentation for the latest version, not the 7.9 docs. The page you’re looking at in the current docs doesn’t exist in the 7.9 docs. Here’s a starting point tho.