Publish Results task fails with an error '[error][SQ] Unable to find report task file'

Must-share information (formatted with Markdown):

  • Publish Quality Gate Result yaml task version 5.1.0
  • Azure DevOps multi-stage pipeline
  • Publish SonarQube report to server
  • It worked before and now doesn’t work

This morning, a new version of the SonarSource.sonarqube.291ed61f-1ee4-45d3-b1b0-bf822d9095ef.SonarQubePublish@5 yaml task was pushed out through the Visual Studio marketplace. Previously, with version 5.0.2, we got the following trace upon success:

Starting: Publish Quality Gate Result
Task : Publish Quality Gate Result
Description : Publish SonarQube’s Quality Gate result on the Azure DevOps build result, to be used after the actual analysis.
Version : 5.0.2
Author : sonarsource
Help : Version: 5.0.2. More Information
Finishing: Publish Quality Gate Result

As of this morning, with version 5.1.0, we now get the following:

SonarQube_PublishTrace.txt (29.3 KB)

Please can you advise is this is an issue or whether we need to provide new configuration for it to work.

1 Like

Hi Bradley. I was having what seems to be the same issue you have.
In case you are using SonarQubePrepare@4 try bumping it to SonarQubePrepare@5. That alone fixed it for me.

If that doesn’t help I believe the issue started because of this commit

I hope that helps.

1 Like

Hi @monkeytennis

Can you please also share your pipeline configuration (how is it looking like since it’s multi-stage) and also the log of the Prepare analysis task ?

Thanks in advance.


Yes, this was the issue. We had a mixture of @4 and @5 tasks and it has been that way for so long that we didn’t know new versions were available.

Thanks for your help on this.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.