Problem upgrading from 4.5.7 to 5.6.7

(Ruben Vilhena) #1

Template for a good bug report, formatted with Markdown:

  • versions used (SonarQube, Scanner, Plugin, and any relevant extension)
    Sonarqube 4.5.7
    Sonarqube 5.6.7

  • error observed (wrap logs/code around triple quote ``` for proper formatting)
    The webserver cannot start and the DB migration can’t be completed.
    Log attached.

  • steps to reproduce
    Installed 4.5.7 successfully.
    Trying to upgrade to 5.6.7.access.txt (151.0 KB)
    sonar.txt (18.1 KB)

  • potential workaround

P.S.: use the #bug:fault sub-category if you’re hitting a specific crash/error , or the #bug:fp sub-category for rules-related behaviour

(Colin Mueller) #2

Greetings,

Just to check, you aren’t installing a fresh v4.5.7 instance, right? It’s a little unclear from your steps to reproduce.

If not, it’s cool that you’re upgrading! Hope you plan on making it all the way from v4.5.7 to the current LTS (6.7) or latest version (7.7)

Based on the logs, I would check and make sure your former SonarQube Service is fully stopped, specifically make sure you have no lingering java processes that maybe didn’t stop all the way.

I’d also give a read to all the Upgrade Notes between v4.5.7 and v5.6. I’ve never actually handled an upgrade between these versions (4.5 was initially released in September 2014), so, unfortunately, I don’t have a lot of common “gotchas” to share.

I would, however, try and browse to the /setup URL it suggests. Maybe in days of SonarQube past, the web server isn’t considered “started” until the database migration has finished.

Best regards,

Colin

(Ruben Vilhena) #3

Hi Colin,

yes, my plan is to go all the way to the latest version.

I don’t think I have any other processes running. I have even tried to reboot the server and it is sill not managing to proceed from that step.

Thanks,
Ruben

(Simon Brandhof) #4

Hi Ruben,

The logs show that you did not browse /setup as mentioned by Colin? Do you confirm? It’s not clear if the form fails to be displayed.

++

1 Like
(Ruben Vilhena) #5

Hi Simon,

browsing to the /set url solved the issue and allow me to trigger the DB update.

Thank you.

Kind regards,
Ruben