Not Able to Find Project to Analyze anymore after Delete

Hope someone can help, on that,

So I deleted a project from sonarcloud that I previous imported from my Azure DevOps organization, and than I want to add it back, but when I go to import a project from organization the project is not listed anymore, I though its about the sync between sonar and ADO but after days its still now showing up, if I create a new project on DevOps it show normally…

There is any recyble bin or hidden feature on Sonar that is preventing me to add back projects that I had deleted?


Welcome to the community!

I’ve just deleted and re-added a project and it worked fine. So can you double-check

  • that you still have full access to the project in your DevOps platform?
  • that there are no browser console errors?


Yes, I checked again. The Service Connection on the Project is Fine, and the Sync with the Organization, too. I created a new Repo in another Project and could see that in Sonar to be added…

But from the Specific project, even new Repos are not synced, and I had one Repo from that project that started to give the same error on analysis that I had with the previous Repo that I have deleted and tried to add back…

I know if I delete this one too I will not be able to find it again. I maybe missing some settings on DevOps side? cant find anything related other than the Service Connection

And there is nothing to do with the PR itself, the PR is there with the correct number


Thanks for the additional detail. I’ve flagged this for more expert eyes.


Hi @vribeirocmp , welcome to our Community!

Could you please verify that the project that you are trying to add is not disabled? Here you can have more information about this Azure DevOps feature. Let me know what you find there, a screenshot would be great!