Node 18.17 deprecated?

We started getting an error in our pipelines today:

ERROR: Unsupported Node.JS version detected 18.17. Please upgrade to the latest Node.JS LTS version.
org.sonar.plugins.javascript.nodejs.NodeCommandException: Unsupported Node.JS version detected 18.17. Please upgrade to the latest Node.JS LTS version.

Announcements & SonarCloud doesn’t show any node 18 deprecations. Is this intentional?

reving to fixed this.


We are also facing this issue, but we don’t have the self-hosted sonar. We are using the SonarCube. Does anyone have any information on this? Is it really deprecated or it is a bug?

Hi @eschumm751, glad to hear bumping the version on the docker image solved this for you.

Hi Marija,

Sorry to hear you are having trouble with this.

Node.js v18 is supported, however, the minimum requirement is Node.js v18.18.
So in your case bumping the minor version should be enough.

Actually, we now embed Node.js for most common platforms precisely to avoid troubles with Node.js versions. However, not all platforms are covered.

Could you share what scanning environment you are using? Docker? Which base image? Something else?

Kind regards,


We expericed the same error in my team, the runner is a self hosted docker, based on image node:20-bookworm, when we log the node version just before the sonar scan, the version is node 20, so it’s probably because the sonar task come with an embeded nodejs.

I think you should fix the sonar scan task (we use SonarSource/sonarcloud-github-action@master).


hi folks,

I am trying to figure out where the problem might be. Github action is using our sonar-scanner-cli docker image 5.0.1, which contains Node.JS 18.17.1 , which should work fine with the analyzer.

Can you pls double check you don’t have some sort of cache and so you are actually not using the latest image?

We use sonarcloud on bitbucket, and the same using the latest pipe sonarsource/sonarqube-scan:2.0.1

This is really bad, having to disable the pipe to get builds through.

Same case here, using sonarsource/sonarqube-scan:2.0.1 on Bitbucket.

@mjgp2 @Agustin_Franco_Di_Ma we’ve just released (today) 2.0.2 for bitbucket. Can you pls give it a try?

Are you sure you published pipe: sonarsource/sonarqube-scan:2.0.2 ?

It looks like you tried to use a pipe in your bitbucket-pipelines.yml that doesn’t exist. Check the name of the pipe and try again.

Workaround for non-JS projects:


Same error here

it might take a while for release to become available, I am trying to find out

Please do, this will be a massive issue if it’s still the case tomorrow.

Any updates please saberduck ?

No update yet, I am investigating the issue

@mjgp2 @Agustin_Franco_Di_Ma just a question, why do you use sonarqube-scan with SonarCloud?
Can you try with sonarsource/sonarcloud-scan:2.0.0 ?

1 Like

This seems to resolve it, which is great, thanks!


Do you have a fix for the task SonarSource/sonarcloud-github-action please ?

We have the fix, I will do the release, it should be available in 2-3 days