No web server when running from zip

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • how is SonarQube deployed: zip, Docker, Helm
  • what are you trying to achieve
  • what have you tried so far to achieve this

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!


SonarQube unzipped and executed as per the online documentation

According to the docs running console should allow login via localhost:9000. However nothing binding to this port so there is no webserver running. ES is running on 9001 and can be reached without issue.

I have tried running console and start.I have also changed the binding IP and Port in the config but this does not make any difference.

We are trying to evaluate this against Semgrep and others, prior to investigating Enterprise licensing, and so far Sonarqube is the only one that has any issues.

What do the logs say?

There are no errors listed in the sonar.log, nohup.log, and es.log. There is no web.log.

Can you share the sonar.log here?

Sorry for the late reply.

Here is the sonar.log:

2024.04.15 12:21:51 INFO  app[][o.s.a.AppFileSystem] Cleaning or creating temp directory /opt/sonarqube-
2024.04.15 12:21:51 INFO  app[][] Elasticsearch listening on [HTTP:, TCP:]
2024.04.15 12:21:51 INFO  app[][o.s.a.ProcessLauncherImpl] Launch process[ELASTICSEARCH] from [/opt/sonarqube-]: /usr/lib/jvm/java-21-openjdk-amd64/bin/java -Xms4m -Xmx64m -XX:+UseSerialGC -Dcli.script=./bin/elasticsearch -Dcli.libs=lib/tools/server-cli -Des.path.home=/opt/sonarqube- -Des.path.conf=/opt/sonarqube- -Des.distribution.type=tar -cp /opt/sonarqube-*:/opt/sonarqube-* org.elasticsearch.launcher.CliToolLauncher
2024.04.15 12:21:51 INFO  app[][o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running

First things first, you need to be using Java 17, not Java 21. This is in the requirements.

1 Like