Sonarqube web process doesn't seem to start

Operating System= EndeavourOs
Deployed Using = Zip

I’ve installed SonarQube community edition for the first time. First followed the instruction from the arch docs to download SonarQube as well as Sonar-scanner. Everytime I ran sonar-scanner sonarqube service would stop. After this, I deleted both sonarQube and sonar-scanner and decided to install using zip by following this article: How to Install SonarQube on Arch Linux | Atlantic.Net. But when i tried to browse localhost:9000 using firefox but it shows Unable to establish connection.

I have tried changing the host from to, the ports, tried checking if any firewall was blocking the ports, tried changing the javaOpts values as well but nothing seems to work
The logs folder does not seem to have a web.log file that I keep seeing mentioned in this forum’s various posts for older versions. As for the other logs (85.3 KB)

Hey there.

It looks like Elasticsearch never succeeds in starting, which means the web server never launches (so that’s why there’s no web.log file).

The error in es.log is pretty clear;

2024.03.10 20:56:14 ERROR es[][o.e.b.Elasticsearch] node validation exception
[2] bootstrap checks failed. You must address the points described in the following [2] lines before starting Elasticsearch. For more information see []
bootstrap check failure [1] of [2]: initial heap size [134217728] not equal to maximum heap size [536870912]; this can cause resize pauses; for more information see []
bootstrap check failure [2] of [2]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]; for more information see []

You can refer to the Platform notes documentation for more help resolving these.