[NEW RELEASE] Sonar PMD Plugin 3.0.1

scanner
plugin

(Jens Gerdes) #1

Dear community,

the RFF period has ended. I consider no feedback to be good feedback - which means we can release the mentioned plugin today.

Highlights:

  • Support SonarQube >=7.3 (#49 , #55)
  • Changed versioning scheme ( MAJOR.MINOR.PATCH )

Information

@Sonar staff: Please update the Market place plugin. Thank you. :slight_smile:


(G Ann Campbell) #2

Hi,

Done.

 
:slight_smile:
Ann


(Jens Gerdes) #3

Thanks @ganncamp

There seems to be a small mistake in the compatibility settings. The plugin is compatible with SonarQube 6.6+.
Could you update the Plugin Version Matrix as well as the configuration in the marketplace?

Regards
Jens


(G Ann Campbell) #4

Hi Jens,

We’ve dropped support for everything before 6.7. The marketplace doesn’t even recognize 6.6 anymore, so even if I did update the compatibility, at 6.6 column wouldn’t be added back in to the compatibility matrix.

 
Ann


(Jens Gerdes) #5

Okay, in that case could you set the compatibility to 6.7+? It seems to be 7.3+ at the moment.


(G Ann Campbell) #6

:flushed: I was looking at the description, not the compatibility I guess.

Fixed.

 
Ann