New analysis in progress running for a while despite analysis was successful

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) - Enterprise Edition Version 10.2.1 SonarQube
  • what are you trying to achieve: see analysis results on web UI after analysis execution success
  • what have you tried so far to achieve this: I have run analysis from local sonar scanner and analysis execution was success. However, the results only show up as overview count in web ui. When I click on each issue like code smells or bugs, it says “We couldn’t find any results matching selected criteria”. The code repository has 2,953,802 lines of code so is that why I cannot see the analysis results in detail? Or is there a way to troubleshoot it? I thought once execution was successful, results should appear on web ui. Is it the case or does it take more time for the web server to analyze the report and show on ui?

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

Hey there.

Do you see anything in the logs?

Hello, the results showed up in the ui now. It took a couple hours to show up so I’m guessing it could be because of local scanner. I will take a look at the log files as suggested for now. In the meantime, is it possible that local scanner take longer to analyze and process the reports than scanning through ci tools?

Once it’s submitted to the server, it should all be the same.

Do you see varying lenghts of time it takes to compute the project’s background tasks? An administrator can check in your project’s Project Settings > Background Tasks

I checked the background tasks and it says it took 5 hour 49 mins. I remember the analysis says it was done after 45 mins or so. So, for the analysis results to fully show up, it took 5 hours approximately. I haven’t had a chance to try with azure pipelines since I’m waiting for permission to integrate with the pipeline. But we ran a different repository with 1.4M lines of code and it took 10 mins to show up the results from Jenkins.

You should be able to find out what is taking so long by looking at your ce.log file – which contains timestamps for each of the steps the compute engine takes while processing the background task.

This operation is also heavily dependent on database performance – what database is backing in your SonarQube server? Postgres, SQL Server, Oracle?

The database we are using is oracle db. Unfortunately, we had to pull down and create the containers again due to storage full so we no longer have access to logs on that date that I ran the local scanner. I will test with other repositories and see if this problem persists.

We are having a warning regarding elastic search so I created another post - could you be able to look at this one? Thank you SonarQube Elastic Search node is locked error