Missing resource strings using Docker Image

Must-share information:

  • Which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    SonarQube 10.3 - Developer Edition
  • How is SonarQube deployed: zip, Docker, Helm
    Docker on Ubuntu with an Nginx proxy
  • What are you trying to achieve
    Fix missing resource strings
  • What have you tried so far to achieve this
    Have tried multiple different versions of the docker image

Starting with SonarQube 9.9 - Developer edition image, there has consistently been missing resource strings evident in the UI.
e.g.: issue.clean_code_attribute_category.CONSISTENT.title_short

Not ALL resource strings are affected by this, but a noticeable amount of them are.

Here are some examples of what I’m seeing:

Looking at sonarqube/sonar-core/src/main/resources/org/sonar/l10n/core.properties at master · SonarSource/sonarqube · GitHub it appears that these resource strings are legitimately missing.


Welcome to the community and thanks for this report!

Are you running the CNES Report plugin? This phenomenon is caused by 3rd-party plugins, and that one will do it. Besides, it’s not compatible with SonarQube 9.9.


Thanks! That was the issue.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.